{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-15661 in the wild and no public exploit code.","fix":"Apply the vendor's patch.","what":"CVE-2025-15661 is a high-severity vulnerability in libssh2, published on 18 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-15661 and fix it if it is affected.\n\nWhat it is: CVE-2025-15661 is a high-severity vulnerability in libssh2, published on 18 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-15661 in the wild and no public exploit code.\n\nAffected product: libssh2. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-15661/ (Markdown: https://insights.sbomify.com/CVE-2025-15661/index.md)","id":"CVE-2025-15661","markdown":"https://insights.sbomify.com/CVE-2025-15661/index.md","name":"CVE-2025-15661","record":{"aliases":["ALPINE-CVE-2025-15661","AZL-90936","BELL-CVE-2025-15661","DEBIAN-CVE-2025-15661","ECHO-16dd-65e4-250c","GHSA-3wqh-87fg-ffgg","JLSEC-2026-659","OESA-2026-3017","RHSA-2026:30132","ROOT-OS-DEBIAN-11-CVE-2025-15661","UBUNTU-CVE-2025-15661"],"analysis":{"component_type":"library","fix_type":"patch","impacts":["data_read","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"SSH client library","requires_auth":"none","summary":"A malicious SSH server can trigger a heap buffer over-read in libssh2, potentially disclosing memory contents or causing a crash.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[{"product":"libssh2","vendor":"libssh2"}],"cvss":{"score":8.3,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:L/VI:N/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-125","name":"Out-of-bounds Read"}],"description":"libssh2 through 1.11.1, fixed in commit 2dae302, contains an out-of-bounds heap read vulnerability in the sftp_symlink() function in src/sftp.c that allows a malicious SSH server or man-in-the-middle attacker to disclose heap memory contents or cause a crash by sending a crafted SSH_FXP_NAME response. Attackers can supply a link_len value larger than the actual packet data in SSH_FXP_NAME responses for SFTP READLINK and REALPATH operations, triggering a heap buffer over-read of up to target_len minus one bytes due to the missing validation of available packet buffer size before the memcpy operation.","ecosystems":["Red Hat:hummingbird:1"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"libssh2 - Heap Buffer Over-read via sftp_symlink() in sftp.c","id":"CVE-2025-15661","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"information_disclosure","year":"2025"},"n_packages":3,"n_references":4,"next":{"headline":"Server-side request forgery in Printcart Web to Print Product Designer for WooCommerce","id":"CVE-2025-15662"},"packages":[{"ecosystem":"Red Hat:hummingbird:1","fixed":["0:1.11.1-9.hum1"],"introduced":["0"],"last_affected":[],"package":"libssh2","purl":"pkg:rpm/redhat/libssh2","source":"RHSA-2026:30132"},{"ecosystem":"Red Hat:hummingbird:1","fixed":["0:1.11.1-9.hum1"],"introduced":["0"],"last_affected":[],"package":"libssh2-devel","purl":"pkg:rpm/redhat/libssh2-devel","source":"RHSA-2026:30132"},{"ecosystem":"Red Hat:hummingbird:1","fixed":["0:1.11.1-9.hum1"],"introduced":["0"],"last_affected":[],"package":"libssh2-docs","purl":"pkg:rpm/redhat/libssh2-docs","source":"RHSA-2026:30132"}],"prev":{"headline":"WordPress Elizaibots plugin \u003c= 1.0.2 - Cross Site Scripting (XSS) vulnerability","id":"CVE-2025-15659"},"products":["libssh2"],"published":"2026-06-18","related":[{"cvss_score":9.2,"headline":"libssh2 - Out-of-Bounds Write via Unchecked packet_length in transport.c","id":"CVE-2026-55200","kev_date_added":null,"published":"2026-06-17"},{"cvss_score":8.7,"headline":"libssh2 Double-Free Heap Corruption via sftp_open()","id":"CVE-2026-66032","kev_date_added":null,"published":"2026-07-24"},{"cvss_score":8.7,"headline":"libssh2 Integer Underflow DoS via AES-GCM Cipher Negotiation","id":"CVE-2026-66033","kev_date_added":null,"published":"2026-07-24"},{"cvss_score":8.3,"headline":"libssh2 - Integer Overflow in publickey Subsystem Attribute Allocation","id":"CVE-2026-58050","kev_date_added":null,"published":"2026-06-28"},{"cvss_score":8.3,"headline":"libssh2 - Free of Uninitialized Pointer in publickey List Cleanup","id":"CVE-2026-58051","kev_date_added":null,"published":"2026-06-28"},{"cvss_score":8.2,"headline":"libssh2 - Pre-Authentication DoS via SSH_MSG_EXT_INFO Handler","id":"CVE-2026-55199","kev_date_added":null,"published":"2026-06-17"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"Red Hat","prefix":"RHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-09-24","vendors":["libssh2"]},"summary":"A malicious SSH server can trigger a heap buffer over-read in libssh2, potentially disclosing memory contents or causing a crash.","url":"https://insights.sbomify.com/CVE-2025-15661/"}