# CVE-2025-1570: Auth bypass in Directorist: AI-Powered Business Directory, Listings & Classified Ads

> Unauthenticated attackers can brute force weak OTPs to reset passwords and take over accounts, including administrators, in the Directorist WordPress plugin.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 28 Feb 2025
- **Updated:** 8 Apr 2026
- **Also known as:** GHSA-cq63-2g3g-qjf5

## What is CVE-2025-1570?

CVE-2025-1570 is a high-severity authentication bypass vulnerability in wpwax Directorist: AI-Powered Business Directory, Listings & Classified Ads, published on 28 Feb 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The Directorist: AI-Powered Business Directory Plugin with Classified Ads Listings plugin for WordPress is vulnerable to privilege escalation via account takeover in all versions up to, and including, 8.1. This is due to the directorist_generate_password_reset_pin_code() and reset_user_password() functions not having enough controls to prevent a successful brute force attack of the OTP to change a password, or verify that a password reset request came from an authorized user. This makes it possible for unauthenticated attackers to generate and brute force an OTP that makes it possible to change any users passwords, including an administrator.

Weakness: CWE-640 (Weak Password Recovery Mechanism for Forgotten Password)

## Which versions are affected by CVE-2025-1570?

It affects 1 product.


Products: Wpwax Directorist.

## How do I fix CVE-2025-1570?

No fix has been published for CVE-2025-1570 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-1570 being exploited?

There is no known exploitation of CVE-2025-1570 in the wild and no public exploit code.

## Other vulnerabilities in wpwax Directorist: AI-Powered Business Directory, Listings & Classified Ads

- [CVE-2023-1888](https://insights.sbomify.com/CVE-2023-1888/): Directorist <= 7.5.4 - Authenticated (Subscriber+) Arbitrary User Password Reset to Privilege Escalation (high 8.8)
- [CVE-2021-24981](https://insights.sbomify.com/CVE-2021-24981/): Directorist – Business Directory Plugin < 7.0.6.2 - CSRF to Remote File Upload (high 7.5)
- [CVE-2023-1889](https://insights.sbomify.com/CVE-2023-1889/): Missing authorization in Directorist: AI-Powered Business Directory, Listings & Classified Ads (medium 6.5)
- [CVE-2022-3961](https://insights.sbomify.com/CVE-2022-3961/): Directorist < 7.4.4 - Subscriber+ Sensitive Information Disclosure (medium 6.5)
- [CVE-2022-3930](https://insights.sbomify.com/CVE-2022-3930/): Directorist < 7.4.2.2 - Subscriber+ Arbitrary User Password Update via IDOR (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-1570 and fix it if it is affected.

What it is: CVE-2025-1570 is a high-severity authentication bypass vulnerability in wpwax Directorist: AI-Powered Business Directory, Listings & Classified Ads, published on 28 Feb 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-1570 in the wild and no public exploit code.

Affected product: wpwax Directorist: AI-Powered Business Directory, Listings & Classified Ads. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-1570/ (Markdown: https://insights.sbomify.com/CVE-2025-1570/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-1570
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-1570
- OSV: https://osv.dev/vulnerability/CVE-2025-1570

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-1570/
Summaries are generated and may contain mistakes; the official description above is the record.
