{"answers":{"affected":"2 open source packages ship an affected version, including mongosh. It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-1691 in the wild and no public exploit code.","fix":"Upgrade mongosh to 2.3.9 or later.","what":"CVE-2025-1691 is a high-severity command injection vulnerability in MongoDB Inc mongosh, published on 27 Feb 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-1691 and fix it if it is affected.\n\nWhat it is: CVE-2025-1691 is a high-severity command injection vulnerability in MongoDB Inc mongosh, published on 27 Feb 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2025-1691 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- mongosh (npm): affected all versions; fixed in 2.3.9\n- mongosh (npm): affected all versions; fixed in 2.3.9\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-1691/ (Markdown: https://insights.sbomify.com/CVE-2025-1691/index.md)","id":"CVE-2025-1691","markdown":"https://insights.sbomify.com/CVE-2025-1691/index.md","name":"CVE-2025-1691","record":{"aliases":["GHSA-43g5-2wr2-q7vj"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"MongoDB Shell","requires_auth":"high_privilege","summary":"An attacker controlling a MongoDB cluster can inject malicious commands via autocomplete, leading to code execution when users trigger tab completion.","user_interaction":"required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mongodb","cpe":[{"product":"mongosh","vendor":"mongodb"}],"cvss":{"score":7.6,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:C/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-74","name":"Improper Neutralization of Special Elements in Output Used by a Downstream Component"}],"description":"The MongoDB Shell may be susceptible to control character injection where an attacker with control of the mongosh autocomplete feature, can use the autocompletion feature to input and run obfuscated malicious text. This requires user interaction in the form of the user using ‘tab’ to autocomplete text that is a prefix of the attacker’s prepared autocompletion. This issue affects mongosh versions prior to 2.3.9. \n\nThe vulnerability is exploitable only when mongosh is connected to a cluster that is partially or fully controlled by an attacker.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"MongoDB Shell may be susceptible to Control Character Injection via autocomplete","id":"CVE-2025-1691","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"command_injection","year":"2025"},"n_packages":2,"n_references":1,"next":{"headline":"MongoDB Shell may be susceptible to control character injection via pasting","id":"CVE-2025-1692"},"packages":[{"ecosystem":"npm","fixed":["2.3.9"],"introduced":["0"],"last_affected":[],"package":"mongosh","purl":null,"source":"GHSA-43g5-2wr2-q7vj"},{"ecosystem":"npm","fixed":["2.3.9"],"introduced":["0"],"last_affected":[],"package":"mongosh","purl":"pkg:npm/mongosh","source":"GHSA-43g5-2wr2-q7vj"}],"prev":{"headline":"ThemeMakers Stripe Checkout \u003c= 1.0.1 - Authenticated (Contributor+) Stored Cross-Site Scripting via Shortcode","id":"CVE-2025-1690"},"products":["mongosh"],"published":"2025-02-27","related":[{"cvss_score":7.5,"headline":"MongoDB Shell may be susceptible to local privilege escalation in Windows","id":"CVE-2025-1756","kev_date_added":null,"published":"2025-02-27"},{"cvss_score":6.3,"headline":"MongoDB Shell may be susceptible to control character injection via pasting","id":"CVE-2025-1692","kev_date_added":null,"published":"2025-02-27"},{"cvss_score":3.9,"headline":"MongoDB Shell may be susceptible to control character Injection via shell output","id":"CVE-2025-1693","kev_date_added":null,"published":"2025-02-27"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-02-27","vendors":["MongoDB Inc"]},"summary":"An attacker controlling a MongoDB cluster can inject malicious commands via autocomplete, leading to code execution when users trigger tab completion.","url":"https://insights.sbomify.com/CVE-2025-1691/"}