# CVE-2025-1691: MongoDB Shell may be susceptible to Control Character Injection via autocomplete

> An attacker controlling a MongoDB cluster can inject malicious commands via autocomplete, leading to code execution when users trigger tab completion.

- **Severity:** High 7.6 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 27 Feb 2025
- **Updated:** 27 Feb 2025
- **Also known as:** GHSA-43g5-2wr2-q7vj

## What is CVE-2025-1691?

CVE-2025-1691 is a high-severity command injection vulnerability in MongoDB Inc mongosh, published on 27 Feb 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

The MongoDB Shell may be susceptible to control character injection where an attacker with control of the mongosh autocomplete feature, can use the autocompletion feature to input and run obfuscated malicious text. This requires user interaction in the form of the user using ‘tab’ to autocomplete text that is a prefix of the attacker’s prepared autocompletion. This issue affects mongosh versions prior to 2.3.9. 

The vulnerability is exploitable only when mongosh is connected to a cluster that is partially or fully controlled by an attacker.

Weakness: CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component)

## Which versions are affected by CVE-2025-1691?

2 open source packages ship an affected version, including mongosh. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mongosh` | npm | All versions | 2.3.9 |
| `mongosh` | npm | All versions | 2.3.9 |

Products: Mongodb Mongosh.

## How do I fix CVE-2025-1691?

Upgrade mongosh to 2.3.9 or later.

## Is CVE-2025-1691 being exploited?

There is no known exploitation of CVE-2025-1691 in the wild and no public exploit code.

## Other vulnerabilities in MongoDB Inc mongosh

- [CVE-2025-1756](https://insights.sbomify.com/CVE-2025-1756/): MongoDB Shell may be susceptible to local privilege escalation in Windows (high 7.5)
- [CVE-2025-1692](https://insights.sbomify.com/CVE-2025-1692/): MongoDB Shell may be susceptible to control character injection via pasting (medium 6.3)
- [CVE-2025-1693](https://insights.sbomify.com/CVE-2025-1693/): MongoDB Shell may be susceptible to control character Injection via shell output (low 3.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-1691 and fix it if it is affected.

What it is: CVE-2025-1691 is a high-severity command injection vulnerability in MongoDB Inc mongosh, published on 27 Feb 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-1691 in the wild and no public exploit code.

Affected packages and fixed versions:
- mongosh (npm): affected all versions; fixed in 2.3.9
- mongosh (npm): affected all versions; fixed in 2.3.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-1691/ (Markdown: https://insights.sbomify.com/CVE-2025-1691/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-1691
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-1691
- OSV: https://osv.dev/vulnerability/CVE-2025-1691

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-1691/
Summaries are generated and may contain mistakes; the official description above is the record.
