{"answers":{"affected":"1 open source package ship an affected version, including nginx. It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-1695 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2025-1695 yet. Limit exposure of the affected software until one is available.","what":"CVE-2025-1695 is a medium-severity denial of service vulnerability in F5 NGINX Unit, published on 4 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-1695 and fix it if it is affected.\n\nWhat it is: CVE-2025-1695 is a medium-severity denial of service vulnerability in F5 NGINX Unit, published on 4 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-1695 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- nginx (Bitnami): affected from 1.29.1; no fix listed\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-1695/ (Markdown: https://insights.sbomify.com/CVE-2025-1695/index.md)","id":"CVE-2025-1695","markdown":"https://insights.sbomify.com/CVE-2025-1695/index.md","name":"CVE-2025-1695","record":{"aliases":["BIT-nginx-2025-1695","GHSA-7w3m-9pfq-8m82"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":true,"product_category":"NGINX Unit Java module","requires_auth":"none","summary":"Remote attackers can trigger an infinite loop in the Java module, causing high CPU usage and limited denial of service.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"f5","cpe":[{"product":"nginx_unit","vendor":"f5"}],"cvss":{"score":6.9,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-835","name":"Loop with Unreachable Exit Condition"}],"description":"In NGINX Unit before version 1.34.2 with the Java Language Module in use, undisclosed requests can lead to an infinite loop and cause an increase in CPU resource utilization.  This vulnerability allows a remote attacker to cause a degradation that can lead to a limited denial-of-service (DoS).  There is no control plane exposure; this is a data plane issue only.  Note: Software versions which have reached End of Technical Support (EoTS) are not evaluated.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"NGINX Unit Java Vulnerability","id":"CVE-2025-1695","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"denial_of_service","year":"2025"},"n_packages":1,"n_references":1,"next":{"headline":"Exposure of Proxy Credentials in Docker Desktop Logs","id":"CVE-2025-1696"},"packages":[{"ecosystem":"Bitnami","fixed":[],"introduced":["1.29.1"],"last_affected":[],"package":"nginx","purl":"pkg:bitnami/nginx","source":"BIT-nginx-2025-1695"}],"prev":{"headline":"MongoDB Shell may be susceptible to control character Injection via shell output","id":"CVE-2025-1693"},"products":["NGINX Unit"],"published":"2025-03-04","related":[{"cvss_score":9.8,"headline":"Memory corruption in n/a","id":"CVE-2019-7401","kev_date_added":null,"published":"2019-02-08"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-03-04","vendors":["F5"]},"summary":"Remote attackers can trigger an infinite loop in the Java module, causing high CPU usage and limited denial of service.","url":"https://insights.sbomify.com/CVE-2025-1695/"}