{"answers":{"affected":"3 open source packages ship an affected version, including libphp, php and php-min. It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-1735 in the wild and no public exploit code.","fix":"Upgrade libphp to a fixed version for your release line: 8.1.33, 8.2.29, 8.3.23 or 8.4.10.","what":"CVE-2025-1735 is a medium-severity vulnerability in Php Php, published on 13 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-1735 and fix it if it is affected.\n\nWhat it is: CVE-2025-1735 is a medium-severity vulnerability in Php Php, published on 13 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-1735 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- libphp (Bitnami): affected all versions; fixed in 8.1.33, 8.2.29, 8.3.23, 8.4.10\n- php (Bitnami): affected all versions; fixed in 8.1.33, 8.2.29, 8.3.23, 8.4.10\n- php-min (Bitnami): affected all versions; fixed in 8.1.33, 8.2.29, 8.3.23, 8.4.10\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-1735/ (Markdown: https://insights.sbomify.com/CVE-2025-1735/index.md)","id":"CVE-2025-1735","markdown":"https://insights.sbomify.com/CVE-2025-1735/index.md","name":"CVE-2025-1735","record":{"aliases":["AZL-65121","AZL-65124","BELL-CVE-2025-1735","BIT-libphp-2025-1735","BIT-php-2025-1735","BIT-php-min-2025-1735","CLSA-2025-1753953101","CLSA-2025-1753963973","CLSA-2025-1753982448","CLSA-2025-1757490210","CLSA-2025-1757523038","CLSA-2025-1761320397","CLSA-2025-1764680377","CLSA-2025-1767000167","DEBIAN-CVE-2025-1735","ECHO-5d7a-e4b1-771a","GHSA-hrwm-9436-5mv3","MINI-cjv8-g63v-83j7","MINI-gw36-hm87-p8h8","MINI-hpwf-cjqh-h42w","MINI-wrwh-3m69-qhcg","UBUNTU-CVE-2025-1735","USN-7648-3"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"PHP pgsql extension","requires_auth":"none","summary":"The PHP pgsql extension fails to check for errors during string escaping, potentially causing application crashes when the Postgres server rejects invalid strings.","user_interaction":"not_required","vuln_class":"null_dereference"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"php","cpe":[{"product":"php","vendor":"php"}],"cvss":{"score":5.9,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-89","name":"Improper Neutralization of Special Elements used in an SQL Command"},{"id":"CWE-476","name":"NULL Pointer Dereference"}],"description":"In PHP versions:8.1.* before 8.1.33, 8.2.* before 8.2.29, 8.3.* before 8.3.23, 8.4.* pgsql and pdo_pgsql escaping functions do not check if the underlying quoting functions returned errors. This could cause crashes if Postgres server rejects the string as invalid.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"pgsql extension does not check for errors during escaping","id":"CVE-2025-1735","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"php:php","products":["php:php"],"type":"null_dereference","year":"2025"},"n_packages":3,"n_references":1,"next":{"headline":"Stream HTTP wrapper header check might omit basic auth header","id":"CVE-2025-1736"},"packages":[{"ecosystem":"Bitnami","fixed":["8.1.33","8.2.29","8.3.23","8.4.10"],"introduced":["0","8.2.0","8.3.0","8.4.0"],"last_affected":[],"package":"libphp","purl":"pkg:bitnami/libphp","source":"BIT-libphp-2025-1735"},{"ecosystem":"Bitnami","fixed":["8.1.33","8.2.29","8.3.23","8.4.10"],"introduced":["0","8.2.0","8.3.0","8.4.0"],"last_affected":[],"package":"php","purl":"pkg:bitnami/php","source":"BIT-php-2025-1735"},{"ecosystem":"Bitnami","fixed":["8.1.33","8.2.29","8.3.23","8.4.10"],"introduced":["0","8.2.0","8.3.0","8.4.0"],"last_affected":[],"package":"php-min","purl":"pkg:bitnami/php-min","source":"BIT-php-min-2025-1735"}],"prev":{"headline":"Streams HTTP wrapper does not fail for headers with invalid name and no colon","id":"CVE-2025-1734"},"products":["PHP"],"published":"2025-07-13","related":[{"cvss_score":10,"headline":"Integer overflow in n/a","id":"CVE-2012-2688","kev_date_added":null,"published":"2012-07-20"},{"cvss_score":10,"headline":"Memory corruption in n/a","id":"CVE-2012-2376","kev_date_added":null,"published":"2012-05-21"},{"cvss_score":10,"headline":"Memory corruption in n/a","id":"CVE-2011-3268","kev_date_added":null,"published":"2011-08-25"},{"cvss_score":10,"headline":"Other in n/a","id":"CVE-2009-4143","kev_date_added":null,"published":"2009-12-21"},{"cvss_score":10,"headline":"Memory corruption in n/a","id":"CVE-2008-5557","kev_date_added":null,"published":"2008-12-23"},{"cvss_score":10,"headline":"Memory corruption in n/a","id":"CVE-2008-2050","kev_date_added":null,"published":"2008-05-05"},{"cvss_score":10,"headline":"Command injection in n/a","id":"CVE-2008-2051","kev_date_added":null,"published":"2008-05-05"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-11-04","vendors":["PHP Group"]},"summary":"The PHP pgsql extension fails to check for errors during string escaping, potentially causing application crashes when the Postgres server rejects invalid strings.","url":"https://insights.sbomify.com/CVE-2025-1735/"}