# CVE-2025-1735: pgsql extension does not check for errors during escaping

> The PHP pgsql extension fails to check for errors during string escaping, potentially causing application crashes when the Postgres server rejects invalid strings.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Jul 2025
- **Updated:** 4 Nov 2025
- **Also known as:** AZL-65121, AZL-65124, BELL-CVE-2025-1735, BIT-libphp-2025-1735, BIT-php-2025-1735, BIT-php-min-2025-1735, CLSA-2025-1753953101, CLSA-2025-1753963973, CLSA-2025-1753982448, CLSA-2025-1757490210, CLSA-2025-1757523038, CLSA-2025-1761320397, CLSA-2025-1764680377, CLSA-2025-1767000167, DEBIAN-CVE-2025-1735, ECHO-5d7a-e4b1-771a, GHSA-hrwm-9436-5mv3, MINI-cjv8-g63v-83j7, MINI-gw36-hm87-p8h8, MINI-hpwf-cjqh-h42w, MINI-wrwh-3m69-qhcg, UBUNTU-CVE-2025-1735, USN-7648-3

## What is CVE-2025-1735?

CVE-2025-1735 is a medium-severity vulnerability in Php Php, published on 13 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In PHP versions:8.1.* before 8.1.33, 8.2.* before 8.2.29, 8.3.* before 8.3.23, 8.4.* pgsql and pdo_pgsql escaping functions do not check if the underlying quoting functions returned errors. This could cause crashes if Postgres server rejects the string as invalid.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command), CWE-476 (NULL Pointer Dereference)

## Which versions are affected by CVE-2025-1735?

3 open source packages ship an affected version, including libphp, php and php-min. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `libphp` | Bitnami | All versions | 8.1.33, 8.2.29, 8.3.23, 8.4.10 |
| `php` | Bitnami | All versions | 8.1.33, 8.2.29, 8.3.23, 8.4.10 |
| `php-min` | Bitnami | All versions | 8.1.33, 8.2.29, 8.3.23, 8.4.10 |

Products: Php Php.

## How do I fix CVE-2025-1735?

Upgrade libphp to a fixed version for your release line: 8.1.33, 8.2.29, 8.3.23 or 8.4.10.

## Is CVE-2025-1735 being exploited?

There is no known exploitation of CVE-2025-1735 in the wild and no public exploit code.

## Other vulnerabilities in Php Php

- [CVE-2012-2688](https://insights.sbomify.com/CVE-2012-2688/): Integer overflow in n/a (critical 10.0)
- [CVE-2012-2376](https://insights.sbomify.com/CVE-2012-2376/): Memory corruption in n/a (critical 10.0)
- [CVE-2011-3268](https://insights.sbomify.com/CVE-2011-3268/): Memory corruption in n/a (critical 10.0)
- [CVE-2009-4143](https://insights.sbomify.com/CVE-2009-4143/): Other in n/a (critical 10.0)
- [CVE-2008-5557](https://insights.sbomify.com/CVE-2008-5557/): Memory corruption in n/a (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-1735 and fix it if it is affected.

What it is: CVE-2025-1735 is a medium-severity vulnerability in Php Php, published on 13 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-1735 in the wild and no public exploit code.

Affected packages and fixed versions:
- libphp (Bitnami): affected all versions; fixed in 8.1.33, 8.2.29, 8.3.23, 8.4.10
- php (Bitnami): affected all versions; fixed in 8.1.33, 8.2.29, 8.3.23, 8.4.10
- php-min (Bitnami): affected all versions; fixed in 8.1.33, 8.2.29, 8.3.23, 8.4.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-1735/ (Markdown: https://insights.sbomify.com/CVE-2025-1735/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-1735
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-1735
- OSV: https://osv.dev/vulnerability/CVE-2025-1735

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-1735/
Summaries are generated and may contain mistakes; the official description above is the record.
