{"answers":{"affected":"3 open source packages ship an affected version, including libphp, php and php-min. It affects 2 products.","exploited":"There is no known exploitation of CVE-2025-1736 in the wild and no public exploit code.","fix":"Upgrade libphp to a fixed version for your release line: 8.1.32, 8.2.28, 8.3.19 or 8.4.5.","what":"CVE-2025-1736 is a medium-severity vulnerability in Php Php, published on 30 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-1736 and fix it if it is affected.\n\nWhat it is: CVE-2025-1736 is a medium-severity vulnerability in Php Php, published on 30 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-1736 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- libphp (Bitnami): affected all versions; fixed in 8.1.32, 8.2.28, 8.3.19, 8.4.5\n- php (Bitnami): affected all versions; fixed in 8.1.32, 8.2.28, 8.3.19, 8.4.5\n- php-min (Bitnami): affected all versions; fixed in 8.1.32, 8.2.28, 8.3.19, 8.4.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-1736/ (Markdown: https://insights.sbomify.com/CVE-2025-1736/index.md)","id":"CVE-2025-1736","markdown":"https://insights.sbomify.com/CVE-2025-1736/index.md","name":"CVE-2025-1736","record":{"aliases":["AZL-59303","AZL-59331","BELL-CVE-2025-1736","BIT-libphp-2025-1736","BIT-php-2025-1736","BIT-php-min-2025-1736","CLSA-2025-1744782851","CLSA-2025-1744875533","CLSA-2025-1746654810","CLSA-2025-1753981912","CLSA-2025-1756322698","CLSA-2025-1756323821","CLSA-2025-1756323917","DEBIAN-CVE-2025-1736","ECHO-f6c8-3b5d-92ed","GHSA-hgf5-96fm-v528","MINI-8gx8-xm5w-hc5p","MINI-fw74-3jqr-phjg","MINI-p223-vr2w-7jrm","MINI-pf6v-w65p-8cp9","UBUNTU-CVE-2025-1736"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"PHP scripting language","requires_auth":"none","summary":"Insufficient validation of end-of-line characters in PHP HTTP wrapper headers may cause Basic Auth headers to be omitted or misinterpreted, potentially bypassing authentication.","user_interaction":"not_required","vuln_class":"other"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"php","cpe":[{"product":"ontap","vendor":"netapp"},{"product":"php","vendor":"php"}],"cvss":{"score":6.3,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"In PHP from 8.1.* before 8.1.32, from 8.2.* before 8.2.28, from 8.3.* before 8.3.19, from 8.4.* before 8.4.5, when user-supplied headers are sent, the insufficient validation of the end-of-line characters may prevent certain headers from being sent or lead to certain headers be misinterpreted.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Stream HTTP wrapper header check might omit basic auth header","id":"CVE-2025-1736","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"php:php","products":["php:php"],"type":"other","year":"2025"},"n_packages":3,"n_references":1,"next":{"headline":"This CVE ID has been rejected or withdrawn by its CVE Numbering Authority.","id":"CVE-2025-1737"},"packages":[{"ecosystem":"Bitnami","fixed":["8.1.32","8.2.28","8.3.19","8.4.5"],"introduced":["0","8.2.0","8.3.0","8.4.0"],"last_affected":[],"package":"libphp","purl":"pkg:bitnami/libphp","source":"BIT-libphp-2025-1736"},{"ecosystem":"Bitnami","fixed":["8.1.32","8.2.28","8.3.19","8.4.5"],"introduced":["0","8.2.0","8.3.0","8.4.0"],"last_affected":[],"package":"php","purl":"pkg:bitnami/php","source":"BIT-php-2025-1736"},{"ecosystem":"Bitnami","fixed":["8.1.32","8.2.28","8.3.19","8.4.5"],"introduced":["0","8.2.0","8.3.0","8.4.0"],"last_affected":[],"package":"php-min","purl":"pkg:bitnami/php-min","source":"BIT-php-min-2025-1736"}],"prev":{"headline":"pgsql extension does not check for errors during escaping","id":"CVE-2025-1735"},"products":["PHP"],"published":"2025-03-30","related":[{"cvss_score":9.8,"headline":"OOB access in ldap_escape","id":"CVE-2024-8932","kev_date_added":null,"published":"2024-11-22"},{"cvss_score":8.7,"headline":"Auth bypass in ONTAP 9","id":"CVE-2026-22049","kev_date_added":null,"published":"2026-07-22"},{"cvss_score":6.9,"headline":"Business logic in ONTAP 9","id":"CVE-2026-22050","kev_date_added":null,"published":"2026-01-12"},{"cvss_score":6.3,"headline":"Streams HTTP wrapper does not fail for headers with invalid name and no colon","id":"CVE-2025-1734","kev_date_added":null,"published":"2025-03-30"},{"cvss_score":6.3,"headline":"Stream HTTP wrapper truncates redirect location to 1024 bytes","id":"CVE-2025-1861","kev_date_added":null,"published":"2025-03-30"},{"cvss_score":5.3,"headline":"Information disclosure in ONTAP 9","id":"CVE-2026-22052","kev_date_added":null,"published":"2026-03-04"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-11-03","vendors":["PHP Group"]},"summary":"Insufficient validation of end-of-line characters in PHP HTTP wrapper headers may cause Basic Auth headers to be omitted or misinterpreted, potentially bypassing authentication.","url":"https://insights.sbomify.com/CVE-2025-1736/"}