CVE-2025-1741 b1gMail Admin Page users.php deserialization

Medium 5.1 Published Updated

Remote attackers can exploit unsafe deserialization in the admin user page to potentially execute arbitrary code, requiring an upgrade to the latest version.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2025-1741?

CVE-2025-1741 is a medium-severity unsafe deserialization vulnerability in b1gMail, published on 27 Feb 2025. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

A vulnerability classified as problematic was found in b1gMail up to 7.4.1-pl1. Affected by this vulnerability is an unknown functionality of the file src/admin/users.php of the component Admin Page. The manipulation of the argument query/q leads to deserialization. The attack can be launched remotely. Upgrading to version 7.4.1-pl2 is able to address this issue. The identifier of the patch is 4816c8b748f6a5b965c8994e2cf10861bf6e68aa. It is recommended to upgrade the affected component. The vendor acted highly professional and even fixed this issue in the discontinued commercial edition as b1gMail 7.4.0-pl3.

Weakness: CWE-502, CWE-20

Which versions are affected by CVE-2025-1741?

How do I fix CVE-2025-1741?

No fix has been published for CVE-2025-1741 yet. Limit exposure of the affected software until one is available.

Upgrade, and only deserialise data from trusted sources or with an allow-list of types. More about Unsafe deserialization.

Is CVE-2025-1741 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-1741 exists.

Sources

Also known as GHSA-8gcm-9r6g-8j3f.

Is CVE-2025-1741 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free