{"answers":{"affected":"","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-1741 exists.","fix":"No fix has been published for CVE-2025-1741 yet. Limit exposure of the affected software until one is available.","what":"CVE-2025-1741 is a medium-severity unsafe deserialization vulnerability in b1gMail, published on 27 Feb 2025. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-1741 and fix it if it is affected.\n\nWhat it is: CVE-2025-1741 is a medium-severity unsafe deserialization vulnerability in b1gMail, published on 27 Feb 2025. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-1741 exists.\n\nAffected product: b1gMail. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-1741/ (Markdown: https://insights.sbomify.com/CVE-2025-1741/index.md)","id":"CVE-2025-1741","markdown":"https://insights.sbomify.com/CVE-2025-1741/index.md","name":"CVE-2025-1741","record":{"aliases":["GHSA-8gcm-9r6g-8j3f"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"b1gMail webmail","requires_auth":"high_privilege","summary":"Remote attackers can exploit unsafe deserialization in the admin user page to potentially execute arbitrary code, requiring an upgrade to the latest version.","user_interaction":"not_required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[],"cvss":{"score":5.1,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-502","name":"Deserialization of Untrusted Data"},{"id":"CWE-20","name":"Improper Input Validation"}],"description":"A vulnerability classified as problematic was found in b1gMail up to 7.4.1-pl1. Affected by this vulnerability is an unknown functionality of the file src/admin/users.php of the component Admin Page. The manipulation of the argument query/q leads to deserialization. The attack can be launched remotely. Upgrading to version 7.4.1-pl2 is able to address this issue. The identifier of the patch is 4816c8b748f6a5b965c8994e2cf10861bf6e68aa. It is recommended to upgrade the affected component. The vendor acted highly professional and even fixed this issue in the discontinued commercial edition as b1gMail 7.4.0-pl3.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":false,"headline":"b1gMail Admin Page users.php deserialization","id":"CVE-2025-1741","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"deserialization","year":"2025"},"n_packages":0,"n_references":7,"next":{"headline":"pihome-shc PiHome home.php cross site scripting","id":"CVE-2025-1742"},"packages":[],"prev":{"headline":"Authentication Bypass in Akinsoft's MyRezzta","id":"CVE-2025-1740"},"products":["b1gMail"],"published":"2025-02-27","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-02-27","vendors":["n/a"]},"summary":"Remote attackers can exploit unsafe deserialization in the admin user page to potentially execute arbitrary code, requiring an upgrade to the latest version.","url":"https://insights.sbomify.com/CVE-2025-1741/"}