# CVE-2025-1741: b1gMail Admin Page users.php deserialization

> Remote attackers can exploit unsafe deserialization in the admin user page to potentially execute arbitrary code, requiring an upgrade to the latest version.

- **Severity:** Medium 5.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 27 Feb 2025
- **Updated:** 27 Feb 2025
- **Also known as:** GHSA-8gcm-9r6g-8j3f

## What is CVE-2025-1741?

CVE-2025-1741 is a medium-severity unsafe deserialization vulnerability in b1gMail, published on 27 Feb 2025. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

A vulnerability classified as problematic was found in b1gMail up to 7.4.1-pl1. Affected by this vulnerability is an unknown functionality of the file src/admin/users.php of the component Admin Page. The manipulation of the argument query/q leads to deserialization. The attack can be launched remotely. Upgrading to version 7.4.1-pl2 is able to address this issue. The identifier of the patch is 4816c8b748f6a5b965c8994e2cf10861bf6e68aa. It is recommended to upgrade the affected component. The vendor acted highly professional and even fixed this issue in the discontinued commercial edition as b1gMail 7.4.0-pl3.

Weakness: CWE-502 (Deserialization of Untrusted Data), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2025-1741?


## How do I fix CVE-2025-1741?

No fix has been published for CVE-2025-1741 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-1741 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-1741 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-1741 and fix it if it is affected.

What it is: CVE-2025-1741 is a medium-severity unsafe deserialization vulnerability in b1gMail, published on 27 Feb 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-1741 exists.

Affected product: b1gMail. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-1741/ (Markdown: https://insights.sbomify.com/CVE-2025-1741/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-1741
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-1741
- OSV: https://osv.dev/vulnerability/CVE-2025-1741

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-1741/
Summaries are generated and may contain mistakes; the official description above is the record.
