{"answers":{"affected":"1 open source package ship an affected version, including opencart. It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-1748 in the wild and no public exploit code.","fix":"Upgrade opencart to 4.1.0 or later.","what":"CVE-2025-1748 is a medium-severity cross-site scripting vulnerability in OpenCart, published on 28 Feb 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-1748 and fix it if it is affected.\n\nWhat it is: CVE-2025-1748 is a medium-severity cross-site scripting vulnerability in OpenCart, published on 28 Feb 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2025-1748 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- opencart (Bitnami): affected all versions; fixed in 4.1.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-1748/ (Markdown: https://insights.sbomify.com/CVE-2025-1748/index.md)","id":"CVE-2025-1748","markdown":"https://insights.sbomify.com/CVE-2025-1748/index.md","name":"CVE-2025-1748","record":{"aliases":["BIT-opencart-2025-1748","GHSA-pm77-vj97-hfv8"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_modify","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"OpenCart e-commerce","requires_auth":"none","summary":"Attackers can inject malicious HTML into the registration page via URL parameters, potentially altering the victim's browser view.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"INCIBE","cpe":[{"product":"opencart","vendor":"opencart"}],"cvss":{"score":4.7,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"HTML injection vulnerabilities in OpenCart versions prior to 4.1.0. These vulnerabilities could allow an attacker to modify the HTML of the victim's browser by sending a malicious URL and modifying the parameter name in /account/register.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"HTML injection vulnerability in OpenCart","id":"CVE-2025-1748","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"xss","year":"2025"},"n_packages":1,"n_references":1,"next":{"headline":"HTML injection vulnerability in OpenCart","id":"CVE-2025-1749"},"packages":[{"ecosystem":"Bitnami","fixed":["4.1.0"],"introduced":["0"],"last_affected":[],"package":"opencart","purl":"pkg:bitnami/opencart","source":"BIT-opencart-2025-1748"}],"prev":{"headline":"HTML injection vulnerability in OpenCart","id":"CVE-2025-1747"},"products":["OpenCart"],"published":"2025-02-28","related":[{"cvss_score":9.8,"headline":"Auth bypass in n/a","id":"CVE-2023-40834","kev_date_added":null,"published":"2023-09-12"},{"cvss_score":9.8,"headline":"Deserialization in n/a","id":"CVE-2014-3990","kev_date_added":null,"published":"2018-03-20"},{"cvss_score":8.8,"headline":"OpenCart Core 4.0.2.3 SQL Injection via search Parameter","id":"CVE-2024-58341","kev_date_added":null,"published":"2026-03-25"},{"cvss_score":8.8,"headline":"Code injection in n/a","id":"CVE-2023-47444","kev_date_added":null,"published":"2023-11-15"},{"cvss_score":8.8,"headline":"OpenCart Cross-Site Request Forgery (CSRF)","id":"CVE-2018-13067","kev_date_added":null,"published":"2018-07-02"},{"cvss_score":8.1,"headline":"Path Traversal in OpenCart versions 4.0.0.0 to 4.0.2.2","id":"CVE-2023-2315","kev_date_added":null,"published":"2023-09-26"},{"cvss_score":8,"headline":"OpenCart Path Traversal","id":"CVE-2018-11494","kev_date_added":null,"published":"2018-05-26"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-02-28","vendors":["OpenCart"]},"summary":"Attackers can inject malicious HTML into the registration page via URL parameters, potentially altering the victim's browser view.","url":"https://insights.sbomify.com/CVE-2025-1748/"}