# CVE-2025-1749: HTML injection vulnerability in OpenCart

> Attackers can inject malicious HTML via URL parameters in the voucher account page, potentially executing scripts in victim browsers.

- **Severity:** Medium 4.7 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 28 Feb 2025
- **Updated:** 28 Feb 2025
- **Also known as:** BIT-opencart-2025-1749, GHSA-hqj8-x5h3-q5rg

## What is CVE-2025-1749?

CVE-2025-1749 is a medium-severity cross-site scripting vulnerability in OpenCart, published on 28 Feb 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

HTML injection vulnerabilities in OpenCart versions prior to 4.1.0. These vulnerabilities could allow an attacker to modify the HTML of the victim's browser by sending a malicious URL and modifying the parameter name in /account/voucher.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-1749?

1 open source package ship an affected version, including opencart. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `opencart` | Bitnami | All versions | 4.1.0 |

Products: Opencart Opencart.

## How do I fix CVE-2025-1749?

Upgrade opencart to 4.1.0 or later.

## Is CVE-2025-1749 being exploited?

There is no known exploitation of CVE-2025-1749 in the wild and no public exploit code.

## Other vulnerabilities in OpenCart

- [CVE-2023-40834](https://insights.sbomify.com/CVE-2023-40834/): Auth bypass in n/a (critical 9.8)
- [CVE-2014-3990](https://insights.sbomify.com/CVE-2014-3990/): Deserialization in n/a (critical 9.8)
- [CVE-2024-58341](https://insights.sbomify.com/CVE-2024-58341/): OpenCart Core 4.0.2.3 SQL Injection via search Parameter (high 8.8)
- [CVE-2023-47444](https://insights.sbomify.com/CVE-2023-47444/): Code injection in n/a (high 8.8)
- [CVE-2018-13067](https://insights.sbomify.com/CVE-2018-13067/): OpenCart Cross-Site Request Forgery (CSRF) (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-1749 and fix it if it is affected.

What it is: CVE-2025-1749 is a medium-severity cross-site scripting vulnerability in OpenCart, published on 28 Feb 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-1749 in the wild and no public exploit code.

Affected packages and fixed versions:
- opencart (Bitnami): affected all versions; fixed in 4.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-1749/ (Markdown: https://insights.sbomify.com/CVE-2025-1749/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-1749
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-1749
- OSV: https://osv.dev/vulnerability/CVE-2025-1749

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-1749/
Summaries are generated and may contain mistakes; the official description above is the record.
