# CVE-2025-1752: Denial of Service in run-llama/llama_index

> An attacker can crash the Python process by exhausting the recursion limit in the KnowledgeBaseWebReader class of the llama_index library.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 May 2025
- **Updated:** 15 Oct 2025
- **Also known as:** GHSA-7c85-87cp-mr6g, PYSEC-2026-1554

## What is CVE-2025-1752?

CVE-2025-1752 is a high-severity denial of service vulnerability in run-llama/llama_index, published on 10 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A Denial of Service (DoS) vulnerability has been identified in the KnowledgeBaseWebReader class of the run-llama/llama_index project, affecting version ~ latest(v0.12.15). The vulnerability arises due to inappropriate secure coding measures, specifically the lack of proper implementation of the max_depth parameter in the get_article_urls function. This allows an attacker to exhaust Python's recursion limit through repeated function calls, leading to resource consumption and ultimately crashing the Python process.

Weakness: CWE-674 (Uncontrolled Recursion)

## Which versions are affected by CVE-2025-1752?

3 open source packages ship an affected version, including llama-index. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `llama-index` | PyPI | From 0.12.15 | 0.12.21 |
| `llama-index` | PyPI | From 0.12.15 | 0.12.21 |
| `llama-index` | PyPI | From 0.12.15 | 0.12.21 |

Products: Llamaindex Llamaindex.

## How do I fix CVE-2025-1752?

Upgrade llama-index to 0.12.21 or later.

## Is CVE-2025-1752 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-1752 exists.

## Other vulnerabilities in run-llama/llama_index

- [CVE-2024-12909](https://insights.sbomify.com/CVE-2024-12909/): SQL Injection to RCE in run-llama/llama_index (critical 10.0)
- [CVE-2025-1793](https://insights.sbomify.com/CVE-2025-1793/): SQL Injection in run-llama/llama_index (critical 9.8)
- [CVE-2025-1750](https://insights.sbomify.com/CVE-2025-1750/): SQL Injection in run-llama/llama_index (critical 9.8)
- [CVE-2024-11958](https://insights.sbomify.com/CVE-2024-11958/): SQL Injection in run-llama/llama_index (critical 9.8)
- [CVE-2024-3271](https://insights.sbomify.com/CVE-2024-3271/): Command Injection in run-llama/llama_index (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-1752 and fix it if it is affected.

What it is: CVE-2025-1752 is a high-severity denial of service vulnerability in run-llama/llama_index, published on 10 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-1752 exists.

Affected packages and fixed versions:
- llama-index (PyPI): affected from 0.12.15; fixed in 0.12.21
- llama-index (PyPI): affected from 0.12.15; fixed in 0.12.21
- llama-index (PyPI): affected from 0.12.15; fixed in 0.12.21

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-1752/ (Markdown: https://insights.sbomify.com/CVE-2025-1752/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-1752
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-1752
- OSV: https://osv.dev/vulnerability/CVE-2025-1752

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-1752/
Summaries are generated and may contain mistakes; the official description above is the record.
