{"answers":{"affected":"4 open source packages ship an affected version, including llama-index-cli and llama-index. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-1753 exists.","fix":"Upgrade llama-index-cli to 0.4.1 or later.","what":"CVE-2025-1753 is a high-severity command injection vulnerability in run-llama/llama_index, published on 28 May 2025. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-1753 and fix it if it is affected.\n\nWhat it is: CVE-2025-1753 is a high-severity command injection vulnerability in run-llama/llama_index, published on 28 May 2025. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-1753 exists.\n\nAffected packages and fixed versions:\n- llama-index-cli (PyPI): affected all versions; fixed in 0.4.1\n- llama-index-cli (PyPI): affected all versions; fixed in 0.4.1\n- llama-index-cli (PyPI): affected all versions; fixed in 0.4.1\n- llama-index (PyPI): affected all versions up to 0.12.20; no fix listed\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-1753/ (Markdown: https://insights.sbomify.com/CVE-2025-1753/index.md)","id":"CVE-2025-1753","markdown":"https://insights.sbomify.com/CVE-2025-1753/index.md","name":"CVE-2025-1753","record":{"aliases":["GHSA-g99h-56mw-8263","PYSEC-2025-246","PYSEC-2026-1557"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Python LLM library","requires_auth":"low_privilege","summary":"Attackers can execute arbitrary shell commands via the CLI files argument, leading to code execution on systems using the library.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"@huntr_ai","cpe":[{"product":"llamaindex","vendor":"llamaindex"}],"cvss":{"score":7.8,"severity":"high","source":"cna","vector":"CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-78","name":"Improper Neutralization of Special Elements used in an OS Command"}],"description":"LLama-Index CLI version v0.12.20 contains an OS command injection vulnerability. The vulnerability arises from the improper handling of the `--files` argument, which is directly passed into `os.system`. An attacker who controls the content of this argument can inject and execute arbitrary shell commands. This vulnerability can be exploited locally if the attacker has control over the CLI arguments, and remotely if a web application calls the LLama-Index CLI with a user-controlled filename. This issue can lead to arbitrary code execution on the affected system.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Command Injection in LLama-Index CLI in run-llama/llama_index","id":"CVE-2025-1753","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"command_injection","year":"2025"},"n_packages":4,"n_references":2,"next":{"headline":"Missing Authentication for Critical Function in GitLab","id":"CVE-2025-1754"},"packages":[{"ecosystem":"PyPI","fixed":[],"introduced":["0"],"last_affected":["0.12.20"],"package":"llama-index","purl":"pkg:pypi/llama-index","source":"PYSEC-2025-246"},{"ecosystem":"PyPI","fixed":["0.4.1"],"introduced":["0"],"last_affected":[],"package":"llama-index-cli","purl":null,"source":"GHSA-g99h-56mw-8263"},{"ecosystem":"PyPI","fixed":["0.4.1"],"introduced":["0"],"last_affected":[],"package":"llama-index-cli","purl":"pkg:pypi/llama-index-cli","source":"GHSA-g99h-56mw-8263"},{"ecosystem":"PyPI","fixed":["0.4.1"],"introduced":["0"],"last_affected":[],"package":"llama-index-cli","purl":"pkg:pypi/llama-index-cli","source":"PYSEC-2026-1557"}],"prev":{"headline":"Denial of Service in run-llama/llama_index","id":"CVE-2025-1752"},"products":["run-llama/llama_index"],"published":"2025-05-28","related":[{"cvss_score":10,"headline":"SQL Injection to RCE in run-llama/llama_index","id":"CVE-2024-12909","kev_date_added":null,"published":"2025-03-20"},{"cvss_score":9.8,"headline":"SQL Injection in run-llama/llama_index","id":"CVE-2025-1793","kev_date_added":null,"published":"2025-06-05"},{"cvss_score":9.8,"headline":"SQL Injection in run-llama/llama_index","id":"CVE-2025-1750","kev_date_added":null,"published":"2025-06-02"},{"cvss_score":9.8,"headline":"SQL Injection in run-llama/llama_index","id":"CVE-2024-11958","kev_date_added":null,"published":"2025-03-20"},{"cvss_score":9.8,"headline":"Command Injection in run-llama/llama_index","id":"CVE-2024-3271","kev_date_added":null,"published":"2024-04-16"},{"cvss_score":9.8,"headline":"SQL injection in llama-index","id":"CVE-2024-23751","kev_date_added":null,"published":"2024-01-22"},{"cvss_score":8.8,"headline":"LlamaIndex includes an exec call for `import {cls_name}`","id":"CVE-2024-45201","kev_date_added":null,"published":"2024-08-22"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-05-28","vendors":["run-llama"]},"summary":"Attackers can execute arbitrary shell commands via the CLI files argument, leading to code execution on systems using the library.","url":"https://insights.sbomify.com/CVE-2025-1753/"}