# CVE-2025-1753: Command Injection in LLama-Index CLI in run-llama/llama_index

> Attackers can execute arbitrary shell commands via the CLI files argument, leading to code execution on systems using the library.

- **Severity:** High 7.8 (`CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 May 2025
- **Updated:** 28 May 2025
- **Also known as:** GHSA-g99h-56mw-8263, PYSEC-2025-246, PYSEC-2026-1557

## What is CVE-2025-1753?

CVE-2025-1753 is a high-severity command injection vulnerability in run-llama/llama_index, published on 28 May 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

LLama-Index CLI version v0.12.20 contains an OS command injection vulnerability. The vulnerability arises from the improper handling of the `--files` argument, which is directly passed into `os.system`. An attacker who controls the content of this argument can inject and execute arbitrary shell commands. This vulnerability can be exploited locally if the attacker has control over the CLI arguments, and remotely if a web application calls the LLama-Index CLI with a user-controlled filename. This issue can lead to arbitrary code execution on the affected system.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2025-1753?

4 open source packages ship an affected version, including llama-index-cli and llama-index. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `llama-index-cli` | PyPI | All versions | 0.4.1 |
| `llama-index-cli` | PyPI | All versions | 0.4.1 |
| `llama-index-cli` | PyPI | All versions | 0.4.1 |
| `llama-index` | PyPI | All versions to 0.12.20 | None |

Products: Llamaindex Llamaindex.

## How do I fix CVE-2025-1753?

Upgrade llama-index-cli to 0.4.1 or later.

## Is CVE-2025-1753 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-1753 exists.

## Other vulnerabilities in run-llama/llama_index

- [CVE-2024-12909](https://insights.sbomify.com/CVE-2024-12909/): SQL Injection to RCE in run-llama/llama_index (critical 10.0)
- [CVE-2025-1793](https://insights.sbomify.com/CVE-2025-1793/): SQL Injection in run-llama/llama_index (critical 9.8)
- [CVE-2025-1750](https://insights.sbomify.com/CVE-2025-1750/): SQL Injection in run-llama/llama_index (critical 9.8)
- [CVE-2024-11958](https://insights.sbomify.com/CVE-2024-11958/): SQL Injection in run-llama/llama_index (critical 9.8)
- [CVE-2024-3271](https://insights.sbomify.com/CVE-2024-3271/): Command Injection in run-llama/llama_index (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-1753 and fix it if it is affected.

What it is: CVE-2025-1753 is a high-severity command injection vulnerability in run-llama/llama_index, published on 28 May 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-1753 exists.

Affected packages and fixed versions:
- llama-index-cli (PyPI): affected all versions; fixed in 0.4.1
- llama-index-cli (PyPI): affected all versions; fixed in 0.4.1
- llama-index-cli (PyPI): affected all versions; fixed in 0.4.1
- llama-index (PyPI): affected all versions up to 0.12.20; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-1753/ (Markdown: https://insights.sbomify.com/CVE-2025-1753/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-1753
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-1753
- OSV: https://osv.dev/vulnerability/CVE-2025-1753

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-1753/
Summaries are generated and may contain mistakes; the official description above is the record.
