# CVE-2025-1756: MongoDB Shell may be susceptible to local privilege escalation in Windows

> Local attackers can escalate privileges on Windows systems by placing a crafted file in a specific directory, affecting MongoDB Shell users.

- **Severity:** High 7.5 (`CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 27 Feb 2025
- **Updated:** 27 Feb 2025
- **Also known as:** GHSA-f5w3-73h4-jpcm

## What is CVE-2025-1756?

CVE-2025-1756 is a high-severity vulnerability in Redhat Enterprise Linux Eus, published on 27 Feb 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

mongosh may be susceptible to local privilege escalation under certain conditions potentially enabling unauthorized actions on a user's system with elevated privilege, when a crafted file is stored in C:\node_modules\. This issue affects mongosh prior to 2.3.0

Weakness: CWE-426 (Untrusted Search Path)

## Which versions are affected by CVE-2025-1756?

2 open source packages ship an affected version, including mongosh. It affects 13 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mongosh` | npm | All versions | 2.3.0 |
| `mongosh` | npm | All versions | 2.3.0 |

Products: Mongodb Mongosh, Redhat Codeready Linux Builder Eus, Redhat Codeready Linux Builder for Arm64 Eus, Redhat Codeready Linux Builder for Ibm Z Systems Eus, Redhat Codeready Linux Builder for Power Little Endian Eus, Redhat Enterprise Linux Eus, Redhat Enterprise Linux for Arm 64, Redhat Enterprise Linux for Arm 64 Eus, Redhat Enterprise Linux for Ibm Z Systems, Redhat Enterprise Linux for Ibm Z Systems Eus, Redhat Enterprise Linux for Power Little Endian Eus, Redhat Enterprise Linux Server Aus, Redhat Enterprise Linux Update Services for Sap Solutions.

## How do I fix CVE-2025-1756?

Upgrade mongosh to 2.3.0 or later.

## Is CVE-2025-1756 being exploited?

There is no known exploitation of CVE-2025-1756 in the wild and no public exploit code.

## Other vulnerabilities in Redhat Enterprise Linux Eus

- [CVE-2025-1691](https://insights.sbomify.com/CVE-2025-1691/): MongoDB Shell may be susceptible to Control Character Injection via autocomplete (high 7.6)
- [CVE-2025-1692](https://insights.sbomify.com/CVE-2025-1692/): MongoDB Shell may be susceptible to control character injection via pasting (medium 6.3)
- [CVE-2025-1693](https://insights.sbomify.com/CVE-2025-1693/): MongoDB Shell may be susceptible to control character Injection via shell output (low 3.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-1756 and fix it if it is affected.

What it is: CVE-2025-1756 is a high-severity vulnerability in Redhat Enterprise Linux Eus, published on 27 Feb 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-1756 in the wild and no public exploit code.

Affected packages and fixed versions:
- mongosh (npm): affected all versions; fixed in 2.3.0
- mongosh (npm): affected all versions; fixed in 2.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-1756/ (Markdown: https://insights.sbomify.com/CVE-2025-1756/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-1756
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-1756
- OSV: https://osv.dev/vulnerability/CVE-2025-1756

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-1756/
Summaries are generated and may contain mistakes; the official description above is the record.
