CVE-2025-1792 Improper Access Control in Mattermost Channel Member API
Authenticated guest users can view metadata about members of public channels due to improper access control enforcement in the API.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-1792?
CVE-2025-1792 is a low-severity missing authorization vulnerability in Mattermost Mattermost Server, published on 30 May 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Mattermost versions 10.7.x <= 10.7.0, 10.5.x <= 10.5.3, 9.11.x <= 9.11.12 fail to properly enforce access controls for guest users accessing channel member information, allowing authenticated guest users to view metadata about members of public channels via the channel members API endpoint.
Weakness: CWE-863
Which versions are affected by CVE-2025-1792?
12 open source packages ship an affected version, including github.com/mattermost/mattermost/server/v8, github.com/mattermost/mattermost-server and github.com/mattermost/mattermost-server/v5. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20250414110750-c23f44fe8ed0 |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20250414110750-c23f44fe8ed0 |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20250414110750-c23f44fe8ed0 |
github.com/mattermost/mattermost/server/v8 Go | From 10.0.0-rc1 | 10.5.4 |
github.com/mattermost/mattermost/server/v8 Go | From 10.0.0-rc1 | 10.5.4 |
github.com/mattermost/mattermost/server/v8 Go | From 10.6.0-rc1 | 10.7.1 |
6 more packages
github.com/mattermost/mattermost/server/v8 Go | From 10.6.0-rc1 | 10.7.1 |
github.com/mattermost/mattermost/server/v8 Go | From 9.0.0-rc1 | 9.11.13 |
github.com/mattermost/mattermost/server/v8 Go | From 9.0.0-rc1 | 9.11.13 |
github.com/mattermost/mattermost-server Go | From 9.0.0-rc1+incompatible | 9.11.13+incompatible, 10.5.4+incompatible, 10.7.1+incompatible |
github.com/mattermost/mattermost-server/v5 Go | All versions | None |
github.com/mattermost/mattermost-server/v6 Go | All versions | None |
Products include Mattermost Mattermost Server.
How do I fix CVE-2025-1792?
Upgrade github.com/mattermost/mattermost/server/v8 to a fixed version for your release line: 8.0.0-20250414110750-c23f44fe8ed0, 10.5.4, 10.7.1 or 9.11.13.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2025-1792 being exploited?
There is no known exploitation of CVE-2025-1792 in the wild and no public exploit code.
Other vulnerabilities in Mattermost Mattermost Server
- CVE-2025-12419 Account takeover on OAuth/OpenID-enabled servers
- CVE-2025-12421 Account Takeover via Code Exchange Endpoint
- CVE-2025-4981 Path Traversal Leading to RCE by Any Authenticated Mattermost User
- CVE-2025-20051 Arbitrary file read via block duplication in Mattermost Boards
- CVE-2025-25279 Arbitrary file read in Mattermost Boards via import & export board archive
Sources
Also known as GHSA-hc6v-386m-93pq, GO-2025-3730.