# CVE-2025-1793: SQL Injection in run-llama/llama_index

> Attackers can inject SQL via vector store integrations to read or modify data, impacting applications using the llama_index library.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Jun 2025
- **Updated:** 5 Jun 2025
- **Also known as:** GHSA-v3c8-3pr6-gr7p, PYSEC-2026-394

## What is CVE-2025-1793?

CVE-2025-1793 is a critical SQL injection vulnerability in run-llama/llama_index, published on 5 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Multiple vector store integrations in run-llama/llama_index version v0.12.21 have SQL injection vulnerabilities. These vulnerabilities allow an attacker to read and write data using SQL, potentially leading to unauthorized access to data of other users depending on the usage of the llama-index library in a web application.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2025-1793?

3 open source packages ship an affected version, including llama-index. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `llama-index` | PyPI | All versions | 0.12.28 |
| `llama-index` | PyPI | All versions | 0.12.28 |
| `llama-index` | PyPI | All versions | 0.12.28 |

Products: Llamaindex Llamaindex.

## How do I fix CVE-2025-1793?

Upgrade llama-index to 0.12.28 or later.

## Is CVE-2025-1793 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-1793 exists.

## Other vulnerabilities in run-llama/llama_index

- [CVE-2024-12909](https://insights.sbomify.com/CVE-2024-12909/): SQL Injection to RCE in run-llama/llama_index (critical 10.0)
- [CVE-2025-1750](https://insights.sbomify.com/CVE-2025-1750/): SQL Injection in run-llama/llama_index (critical 9.8)
- [CVE-2024-11958](https://insights.sbomify.com/CVE-2024-11958/): SQL Injection in run-llama/llama_index (critical 9.8)
- [CVE-2024-3271](https://insights.sbomify.com/CVE-2024-3271/): Command Injection in run-llama/llama_index (critical 9.8)
- [CVE-2024-23751](https://insights.sbomify.com/CVE-2024-23751/): SQL injection in llama-index (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-1793 and fix it if it is affected.

What it is: CVE-2025-1793 is a critical SQL injection vulnerability in run-llama/llama_index, published on 5 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-1793 exists.

Affected packages and fixed versions:
- llama-index (PyPI): affected all versions; fixed in 0.12.28
- llama-index (PyPI): affected all versions; fixed in 0.12.28
- llama-index (PyPI): affected all versions; fixed in 0.12.28

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-1793/ (Markdown: https://insights.sbomify.com/CVE-2025-1793/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-1793
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-1793
- OSV: https://osv.dev/vulnerability/CVE-2025-1793

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-1793/
Summaries are generated and may contain mistakes; the official description above is the record.
