CVE-2025-1802 Cross-site scripting in HT Mega Addons for Elementor – Elementor Widgets & Template Builder
Authenticated contributors can inject arbitrary scripts via widget parameters, leading to stored XSS execution for other users.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- None listed
What is CVE-2025-1802?
CVE-2025-1802 is a medium-severity cross-site scripting vulnerability in devitemsllc HT Mega Addons for Elementor – Elementor Widgets & Template Builder, published on 20 Mar 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
The HT Mega – Absolute Addons For Elementor plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘marker_title’, 'notification_content', and 'stt_button_text' parameters in all versions up to, and including, 2.8.3 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The vulnerability was partially patched in version 2.8.3.
Weakness: CWE-79
Which versions are affected by CVE-2025-1802?
It affects 1 product.
Products include Hasthemes Ht Mega.
How do I fix CVE-2025-1802?
No fix has been published for CVE-2025-1802 yet. Limit exposure of the affected software until one is available.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2025-1802 being exploited?
There is no known exploitation of CVE-2025-1802 in the wild and no public exploit code.
Other vulnerabilities in devitemsllc HT Mega Addons for Elementor – Elementor Widgets & Template Builder
- CVE-2023-37999 WordPress HT Mega Absolute Addons for Elementor plugin <= 2.2.0 - Unauthenticated Privilege Escalation vulnerability
- CVE-2024-1974 HT Mega – Absolute Addons For Elementor <= 2.4.5 - Authenticated (Contributor+) Directory Traversal
- CVE-2023-6214 HT Mega – Absolute Addons For Elementor <= 2.4.6 - Sensitive Information Exposure via purchased_products
- CVE-2023-50901 WordPress HT Mega Plugin <= 2.3.8 is vulnerable to Cross Site Scripting (XSS)
- CVE-2024-38706 WordPress HT Mega plugin <= 2.5.7 - JSON Path Traversal vulnerability
Sources
Also known as GHSA-j46h-c723-q9rm.