{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2025-1860 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2025-1860 is a high-severity vulnerability in ZEFRAM Data::Entropy, published on 28 Mar 2025. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-1860 and fix it if it is affected.\n\nWhat it is: CVE-2025-1860 is a high-severity vulnerability in ZEFRAM Data::Entropy, published on 28 Mar 2025. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-1860 in the wild and no public exploit code.\n\nAffected product: ZEFRAM Data::Entropy. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-1860/ (Markdown: https://insights.sbomify.com/CVE-2025-1860/index.md)","id":"CVE-2025-1860","markdown":"https://insights.sbomify.com/CVE-2025-1860/index.md","name":"CVE-2025-1860","record":{"aliases":["DEBIAN-CVE-2025-1860","DLA-4100-1","GHSA-g3hm-j3wc-jcg9","MGASA-2025-0279","UBUNTU-CVE-2025-1860","openSUSE-SU-2025:0123-1","openSUSE-SU-2025:14960-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Perl entropy library","requires_auth":"none","summary":"The Data::Entropy Perl library uses insecure random number generation for cryptographic functions, potentially compromising security.","user_interaction":"not_required","vuln_class":"weak_cryptography"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"CPANSec","cpe":[],"cvss":{"score":7.7,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-338","name":"Use of Cryptographically Weak Pseudo-Random Number Generator (PRNG)"},{"id":"CWE-331","name":"Insufficient Entropy"}],"description":"Data::Entropy for Perl 0.007 and earlier use the rand() function as the default source of entropy, which is not cryptographically secure, for cryptographic functions.","ecosystems":["SUSE:Package Hub 15 SP6","openSUSE:Leap 15.6","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Data::Entropy for Perl uses insecure rand() function for cryptographic functions","id":"CVE-2025-1860","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"weak_cryptography","year":"2025"},"n_packages":3,"n_references":2,"next":{"headline":"Stream HTTP wrapper truncates redirect location to 1024 bytes","id":"CVE-2025-1861"},"packages":[{"ecosystem":"SUSE:Package Hub 15 SP6","fixed":["0.8.0-bp156.4.3.1"],"introduced":["0"],"last_affected":[],"package":"perl-Data-Entropy","purl":"pkg:rpm/suse/perl-Data-Entropy\u0026distro=SUSE%20Package%20Hub%2015%20SP6","source":"openSUSE-SU-2025:0123-1"},{"ecosystem":"openSUSE:Leap 15.6","fixed":["0.8.0-bp156.4.3.1"],"introduced":["0"],"last_affected":[],"package":"perl-Data-Entropy","purl":"pkg:rpm/opensuse/perl-Data-Entropy\u0026distro=openSUSE%20Leap%2015.6","source":"openSUSE-SU-2025:0123-1"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["0.8.0-1.1"],"introduced":["0"],"last_affected":[],"package":"perl-Data-Entropy","purl":"pkg:rpm/opensuse/perl-Data-Entropy\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2025:14960-1"}],"prev":{"headline":"PHPGurukul News Portal login.php sql injection","id":"CVE-2025-1859"},"products":["Data::Entropy"],"published":"2025-03-28","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-09-05","vendors":["ZEFRAM"]},"summary":"The Data::Entropy Perl library uses insecure random number generation for cryptographic functions, potentially compromising security.","url":"https://insights.sbomify.com/CVE-2025-1860/"}