CVE-2025-1861 Stream HTTP wrapper truncates redirect location to 1024 bytes
PHP's HTTP wrapper truncates redirect locations to 1024 bytes, potentially causing incorrect redirections due to non-compliance with RFC9110 recommendations.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-1861?
CVE-2025-1861 is a medium-severity vulnerability in Php Php, published on 30 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
In PHP from 8.1.* before 8.1.32, from 8.2.* before 8.2.28, from 8.3.* before 8.3.19, from 8.4.* before 8.4.5, when parsing HTTP redirect in the response to an HTTP request, there is currently limit on the location value size caused by limited size of the location buffer to 1024. However as per RFC9110, the limit is recommended to be 8000. This may lead to incorrect URL truncation and redirecting to a wrong location.
Weakness: CWE-131
Which versions are affected by CVE-2025-1861?
3 open source packages ship an affected version, including libphp, php and php-min. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
libphp Bitnami | All versions | 8.1.32, 8.2.28, 8.3.19, 8.4.5 |
php Bitnami | All versions | 8.1.32, 8.2.28, 8.3.19, 8.4.5 |
php-min Bitnami | All versions | 8.1.32, 8.2.28, 8.3.19, 8.4.5 |
Products include Netapp Ontap, Php Php.
How do I fix CVE-2025-1861?
Upgrade libphp to a fixed version for your release line: 8.1.32, 8.2.28, 8.3.19 or 8.4.5.
Is CVE-2025-1861 being exploited?
There is no known exploitation of CVE-2025-1861 in the wild and no public exploit code.
Other vulnerabilities in Php Php
Sources
Also known as AZL-59306, AZL-59330, BELL-CVE-2025-1861, BIT-libphp-2025-1861, BIT-php-2025-1861, BIT-php-min-2025-1861 and 10 more.