# CVE-2025-1908: Business Logic Errors in GitLab

> Attackers can track user browsing activities to potentially achieve full account takeover in GitLab.

- **Severity:** High 7.7 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 24 Apr 2025
- **Updated:** 24 Apr 2025
- **Also known as:** BIT-gitlab-2025-1908, GHSA-h38g-w8gh-4m6m, UBUNTU-CVE-2025-1908

## What is CVE-2025-1908?

CVE-2025-1908 is a high-severity vulnerability in Gitlab Gitlab, published on 24 Apr 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

An issue has been discovered in GitLab EE/CE that could allow an attacker to track users' browsing activities, potentially leading to full account take-over, affecting all versions from 16.6 before 17.9.7, 17.10 before 17.10.5, and 17.11 before 17.11.1.

Weakness: CWE-840

## Which versions are affected by CVE-2025-1908?

1 open source package ship an affected version, including gitlab. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gitlab` | Bitnami | From 16.6.0 | 17.11.1 |

Products: Gitlab Gitlab.

## How do I fix CVE-2025-1908?

Upgrade gitlab to 17.11.1 or later.

## Is CVE-2025-1908 being exploited?

There is no known exploitation of CVE-2025-1908 in the wild and no public exploit code.

## Other vulnerabilities in Gitlab Gitlab

- [CVE-2026-97229](https://insights.sbomify.com/CVE-2026-97229/): GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound (critical 10.0, exploited in the wild)
- [CVE-2026-85706](https://insights.sbomify.com/CVE-2026-85706/): GitLab Community Edition and Enterprise Edition Path Traversal (critical 10.0, exploited in the wild)
- [CVE-2023-7028](https://insights.sbomify.com/CVE-2023-7028/): GitLab Community and Enterprise Editions Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2021-22205](https://insights.sbomify.com/CVE-2021-22205/): GitLab Community and Enterprise Editions Remote Code Execution (critical 10.0, exploited in the wild)
- [CVE-2021-39935](https://insights.sbomify.com/CVE-2021-39935/): GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF) (medium 6.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-1908 and fix it if it is affected.

What it is: CVE-2025-1908 is a high-severity vulnerability in Gitlab Gitlab, published on 24 Apr 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-1908 in the wild and no public exploit code.

Affected packages and fixed versions:
- gitlab (Bitnami): affected from 16.6.0; fixed in 17.11.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-1908/ (Markdown: https://insights.sbomify.com/CVE-2025-1908/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-1908
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-1908
- OSV: https://osv.dev/vulnerability/CVE-2025-1908

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-1908/
Summaries are generated and may contain mistakes; the official description above is the record.
