# CVE-2025-1974: ingress-nginx admission controller RCE escalation

> Unauthenticated attackers with pod network access can achieve remote code execution in the ingress-nginx controller, exposing cluster secrets.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Mar 2025
- **Updated:** 26 Feb 2026
- **Also known as:** GHSA-mgvx-rpfc-9mpv, GO-2025-3567, MINI-22gx-v63r-9mwr, MINI-236g-p7hj-q93f, MINI-5w3g-h4pv-c8qw, MINI-88m4-8x6w-2rhh, MINI-g4h6-24f3-mfmh, MINI-gmp8-w4q4-rfr2, MINI-pj7x-rgqj-rrmv, MINI-r29p-pfh8-m32m, MINI-rrpf-hrgf-hfh2, MINI-v5cx-6mxf-fhf6, openSUSE-SU-2025:14941-1, openSUSE-SU-2025:14942-1, openSUSE-SU-2025:14943-1, openSUSE-SU-2025:14944-1, openSUSE-SU-2025:15083-1, openSUSE-SU-2025:15569-1, openSUSE-SU-2026:10050-1, openSUSE-SU-2026:10799-1, openSUSE-SU-2026:11842-1

## What is CVE-2025-1974?

CVE-2025-1974 is a critical code injection vulnerability in kubernetes ingress-nginx, published on 24 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A security issue was discovered in Kubernetes where under certain conditions, an unauthenticated attacker with access to the pod network can achieve arbitrary code execution in the context of the ingress-nginx controller. This can lead to disclosure of Secrets accessible to the controller. (Note that in the default installation, the controller can access all Secrets cluster-wide.)

Weakness: CWE-653 (Improper Isolation or Compartmentalization)

## Which versions are affected by CVE-2025-1974?

5 open source packages ship an affected version, including k8s.io/ingress-nginx.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `k8s.io/ingress-nginx` | Go | All versions | None |
| `k8s.io/ingress-nginx` | Go | All versions | 1.11.5 |
| `k8s.io/ingress-nginx` | Go | All versions | 1.11.5 |
| `k8s.io/ingress-nginx` | Go | From 1.12.0-beta.0 | 1.12.1 |
| `k8s.io/ingress-nginx` | Go | From 1.12.0-beta.0 | 1.12.1 |
| `rke2` | openSUSE:Tumbleweed | All versions | 1.32.3+rke2r1-1.1 |
| `rke2-1.29` | openSUSE:Tumbleweed | All versions | 1.29.15+rke2r1-1.1 |
| `rke2-1.30` | openSUSE:Tumbleweed | All versions | 1.30.11+rke2r1-1.1 |
| `rke2-1.31` | openSUSE:Tumbleweed | All versions | 1.31.7+rke2r1-1.1 |
| `rke2-1.32` | openSUSE:Tumbleweed | All versions | 1.32.4+rke2r1-1.1 |
| `rke2-1.33` | openSUSE:Tumbleweed | All versions | 1.33.5+rke2r1-1.1 |
| `rke2-1.34` | openSUSE:Tumbleweed | All versions | 1.34.3+rke2r1-1.1 |
| `rke2-1.35` | openSUSE:Tumbleweed | All versions | 1.35.4+rke2r1-1.1 |
| `rke2-1.36` | openSUSE:Tumbleweed | All versions | 1.36.4+rke2r1-1.1 |

## How do I fix CVE-2025-1974?

Upgrade k8s.io/ingress-nginx to a fixed version for your release line: 1.11.5 or 1.12.1.

## Is CVE-2025-1974 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-1974 exists.

Public exploit code:

- IngressNightmare POC. world first non-blind remote execution exploitation with multi-advanced exploitation methods. allow on disk exploitation. CVE-2025-24514 - auth-url injection, CVE-2025-1097 - auth-tls-match-cn injection, CVE-2025-1098 – mirror UID injection -- all available.  (github_poc): https://github.com/Esonhugh/ingressNightmare-CVE-2025-1974-exps
- CVE-2025-1974 (github_poc): https://github.com/sandumjacob/IngressNightmare-POCs
- https://github.com/yoshino-s/CVE-2025-1974 (github_poc): https://github.com/yoshino-s/CVE-2025-1974
- Poc for Ingress RCE  (github_poc): https://github.com/zwxxb/CVE-2025-1974
- PoC of CVE-2025-1974, modified from the world-first PoC~ (github_poc): https://github.com/hi-unc1e/CVE-2025-1974-poc
- PoC for CVE-2025-1974: Critical RCE in Ingress-NGINX (<v1.12.1) via unsafe config injection. Exploitable from the pod network without credentials, enabling code execution and potential cluster takeover. Fixed in v1.12.1 and v1.11.5. For research/education only. (github_poc): https://github.com/1w4y/IngressNightmare-RCE-POC

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-1974 and fix it if it is affected.

What it is: CVE-2025-1974 is a critical code injection vulnerability in kubernetes ingress-nginx, published on 24 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-1974 exists.

Affected packages and fixed versions:
- k8s.io/ingress-nginx (Go): affected all versions; no fix listed
- k8s.io/ingress-nginx (Go): affected all versions; fixed in 1.11.5
- k8s.io/ingress-nginx (Go): affected all versions; fixed in 1.11.5
- k8s.io/ingress-nginx (Go): affected from 1.12.0-beta.0; fixed in 1.12.1
- k8s.io/ingress-nginx (Go): affected from 1.12.0-beta.0; fixed in 1.12.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-1974/ (Markdown: https://insights.sbomify.com/CVE-2025-1974/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-1974
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-1974
- OSV: https://osv.dev/vulnerability/CVE-2025-1974

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-1974/
Summaries are generated and may contain mistakes; the official description above is the record.
