{"answers":{"affected":"3 open source packages ship an affected version, including ray.","exploited":"There is no known exploitation of CVE-2025-1979 in the wild and no public exploit code.","fix":"Upgrade ray to 2.43.0 or later.","what":"CVE-2025-1979 is a medium-severity vulnerability in ray, published on 6 Mar 2025. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-1979 and fix it if it is affected.\n\nWhat it is: CVE-2025-1979 is a medium-severity vulnerability in ray, published on 6 Mar 2025. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-1979 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- ray (PyPI): affected all versions; fixed in 2.43.0\n- ray (PyPI): affected all versions; fixed in 2.43.0\n- ray (PyPI): affected all versions; fixed in 2.43.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-1979/ (Markdown: https://insights.sbomify.com/CVE-2025-1979/index.md)","id":"CVE-2025-1979","markdown":"https://insights.sbomify.com/CVE-2025-1979/index.md","name":"CVE-2025-1979","record":{"aliases":["GHSA-w4rh-fgx7-q63m","PYSEC-2025-23"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"adjacent_or_local","non_default_config":true,"product_category":"Ray distributed computing","requires_auth":"low_privilege","summary":"Attackers with log access can steal Redis passwords from Ray logs, requiring log access and password auth.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"snyk","cpe":[],"cvss":{"score":5.7,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:L/AC:L/AT:P/PR:L/UI:N/VC:H/VI:N/VA:N/SC:L/SI:L/SA:N","version":"4.0"},"cwes":[{"id":"CWE-532","name":"Insertion of Sensitive Information into Log File"}],"description":"Versions of the package ray before 2.43.0 are vulnerable to Insertion of Sensitive Information into Log File where the redis password is being logged in the standard logging. If the redis password is passed as an argument, it will be logged and could potentially leak the password.\r\rThis is only exploitable if:\r\r1) Logging is enabled;\r\r2) Redis is using password authentication;\r\r3) Those logs are accessible to an attacker, who can reach that redis instance.\r\r**Note:**\r\rIt is recommended that anyone who is running in this configuration should update to the latest version of Ray, then rotate their redis password.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"ray vulnerable to Insertion of Sensitive Information into Log File","id":"CVE-2025-1979","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"information_disclosure","year":"2025"},"n_packages":3,"n_references":4,"next":{"headline":"Remote Code Execution via Unrestricted File Upload in Ready_","id":"CVE-2025-1980"},"packages":[{"ecosystem":"PyPI","fixed":["2.43.0"],"introduced":["0"],"last_affected":[],"package":"ray","purl":null,"source":"GHSA-w4rh-fgx7-q63m"},{"ecosystem":"PyPI","fixed":["2.43.0"],"introduced":["0"],"last_affected":[],"package":"ray","purl":"pkg:pypi/ray","source":"GHSA-w4rh-fgx7-q63m"},{"ecosystem":"PyPI","fixed":["2.43.0"],"introduced":["0"],"last_affected":[],"package":"ray","purl":"pkg:pypi/ray","source":"PYSEC-2025-23"}],"prev":{"headline":"Remote Code Execution Vulnerability in Hitachi Storage Navigator and the maintenance console","id":"CVE-2025-1978"},"products":["ray"],"published":"2025-03-06","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-03-06","vendors":["n/a"]},"summary":"Attackers with log access can steal Redis passwords from Ray logs, requiring log access and password auth.","url":"https://insights.sbomify.com/CVE-2025-1979/"}