CVE-2025-2000 Qiskit SDK code execution
Attackers can execute arbitrary code by tricking users into loading maliciously crafted QPY files with the Qiskit SDK.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-2000?
CVE-2025-2000 is a critical unsafe deserialization vulnerability in IBM Qiskit SDK, published on 14 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
A maliciously crafted QPY file can potential execute arbitrary-code embedded in the payload without privilege escalation when deserialising QPY formats < 13. A python process calling Qiskit 0.18.0 through 1.4.1's `qiskit.qpy.load()` function could potentially execute any arbitrary Python code embedded in the correct place in the binary file as part of specially constructed payload.
Weakness: CWE-502
Which versions are affected by CVE-2025-2000?
8 open source packages ship an affected version, including qiskit and qiskit-terra. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
qiskit PyPI | All versions | 1.4.2, 2.0.0rc2 |
qiskit PyPI | All versions | 1.4.2 |
qiskit PyPI | All versions | 1.4.2 |
qiskit PyPI | From 2.0.0rc1 | 2.0.0rc2 |
qiskit PyPI | From 2.0.0rc1 | 2.0.0rc2 |
qiskit-terra PyPI | From 0.18.0 to 0.46.3 | None |
2 more packages
qiskit-terra PyPI | From 0.18.0 to 0.46.3 | None |
qiskit-terra PyPI | From 0.18.0 to 0.46.3 | None |
Products include Ibm Qiskit.
How do I fix CVE-2025-2000?
Upgrade qiskit to a fixed version for your release line: 1.4.2 or 2.0.0rc2.
Upgrade, and only deserialise data from trusted sources or with an allow-list of types. More about Unsafe deserialization.
Is CVE-2025-2000 being exploited?
There is no known exploitation of CVE-2025-2000 in the wild and no public exploit code.
Other vulnerabilities in IBM Qiskit SDK
Sources
Also known as GHSA-6m2c-76ff-6vrf, PYSEC-2026-510, PYSEC-2026-511.