# CVE-2025-2000: Qiskit SDK code execution

> Attackers can execute arbitrary code by tricking users into loading maliciously crafted QPY files with the Qiskit SDK.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Mar 2025
- **Updated:** 26 Feb 2026
- **Also known as:** GHSA-6m2c-76ff-6vrf, PYSEC-2026-510, PYSEC-2026-511

## What is CVE-2025-2000?

CVE-2025-2000 is a critical unsafe deserialization vulnerability in IBM Qiskit SDK, published on 14 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A maliciously crafted QPY file can potential execute arbitrary-code embedded in the payload without privilege escalation when deserialising QPY formats < 13. A python process calling Qiskit 0.18.0 through 1.4.1's `qiskit.qpy.load()` function could potentially execute any arbitrary Python code embedded in the correct place in the binary file as part of specially constructed payload.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2025-2000?

8 open source packages ship an affected version, including qiskit and qiskit-terra. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `qiskit` | PyPI | All versions | 1.4.2, 2.0.0rc2 |
| `qiskit` | PyPI | All versions | 1.4.2 |
| `qiskit` | PyPI | All versions | 1.4.2 |
| `qiskit` | PyPI | From 2.0.0rc1 | 2.0.0rc2 |
| `qiskit` | PyPI | From 2.0.0rc1 | 2.0.0rc2 |
| `qiskit-terra` | PyPI | From 0.18.0 to 0.46.3 | None |
| `qiskit-terra` | PyPI | From 0.18.0 to 0.46.3 | None |
| `qiskit-terra` | PyPI | From 0.18.0 to 0.46.3 | None |

Products: Ibm Qiskit.

## How do I fix CVE-2025-2000?

Upgrade qiskit to a fixed version for your release line: 1.4.2 or 2.0.0rc2.

## Is CVE-2025-2000 being exploited?

There is no known exploitation of CVE-2025-2000 in the wild and no public exploit code.

## Other vulnerabilities in IBM Qiskit SDK

- [CVE-2025-1403](https://insights.sbomify.com/CVE-2025-1403/): Qiskit SDK denial of service (high 8.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-2000 and fix it if it is affected.

What it is: CVE-2025-2000 is a critical unsafe deserialization vulnerability in IBM Qiskit SDK, published on 14 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-2000 in the wild and no public exploit code.

Affected packages and fixed versions:
- qiskit (PyPI): affected all versions; fixed in 1.4.2, 2.0.0rc2
- qiskit (PyPI): affected all versions; fixed in 1.4.2
- qiskit (PyPI): affected all versions; fixed in 1.4.2
- qiskit (PyPI): affected from 2.0.0rc1; fixed in 2.0.0rc2
- qiskit (PyPI): affected from 2.0.0rc1; fixed in 2.0.0rc2
- qiskit-terra (PyPI): affected from 0.18.0 up to 0.46.3; no fix listed
- qiskit-terra (PyPI): affected from 0.18.0 up to 0.46.3; no fix listed
- qiskit-terra (PyPI): affected from 0.18.0 up to 0.46.3; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-2000/ (Markdown: https://insights.sbomify.com/CVE-2025-2000/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-2000
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-2000
- OSV: https://osv.dev/vulnerability/CVE-2025-2000

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-2000/
Summaries are generated and may contain mistakes; the official description above is the record.
