CVE-2025-20033 DoS via custom post type for sysconsole plugin readers
Attackers can cause denial of service for users with plugin read permissions by creating posts with specific custom types in Mattermost.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-20033?
CVE-2025-20033 is a medium-severity denial of service vulnerability in Mattermost Mattermost Server, published on 9 Jan 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Mattermost versions 10.2.0, 9.11.x <= 9.11.5, 10.0.x <= 10.0.3, 10.1.x <= 10.1.3 fail to properly validate post types, which allows attackers to deny service to users with the sysconsole_read_plugins permission via creating a post with the custom_pl_notification type and specific props.
Weakness: CWE-1287
Which versions are affected by CVE-2025-20033?
14 open source packages ship an affected version, including github.com/mattermost/mattermost/server/v8, github.com/mattermost/mattermost-server and github.com/mattermost/mattermost-server/v5. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20250102081831-64c566a8280b |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20250102081831-64c566a8280b |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20250102081831-64c566a8280b |
github.com/mattermost/mattermost/server/v8 Go | From 10.0.0 | 10.0.4 |
github.com/mattermost/mattermost/server/v8 Go | From 10.0.0 | 10.0.4 |
github.com/mattermost/mattermost/server/v8 Go | From 10.1.0 | 10.1.4 |
8 more packages
github.com/mattermost/mattermost/server/v8 Go | From 10.1.0 | 10.1.4 |
github.com/mattermost/mattermost/server/v8 Go | From 10.2.0 | 10.2.1 |
github.com/mattermost/mattermost/server/v8 Go | From 10.2.0 | 10.2.1 |
github.com/mattermost/mattermost/server/v8 Go | From 9.11.0 | 9.11.16 |
github.com/mattermost/mattermost/server/v8 Go | From 9.11.0 | 9.11.16 |
github.com/mattermost/mattermost-server Go | From 10.0.0+incompatible | 10.0.4+incompatible, 10.1.4+incompatible, 10.2.1+incompatible |
github.com/mattermost/mattermost-server/v5 Go | All versions | None |
github.com/mattermost/mattermost-server/v6 Go | All versions | None |
Products include Mattermost Mattermost Server.
How do I fix CVE-2025-20033?
Upgrade github.com/mattermost/mattermost/server/v8 to a fixed version for your release line: 8.0.0-20250102081831-64c566a8280b, 10.0.4, 10.1.4 or 10.2.1.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2025-20033 being exploited?
There is no known exploitation of CVE-2025-20033 in the wild and no public exploit code.
Other vulnerabilities in Mattermost Mattermost Server
- CVE-2025-12419 Account takeover on OAuth/OpenID-enabled servers
- CVE-2025-12421 Account Takeover via Code Exchange Endpoint
- CVE-2025-4981 Path Traversal Leading to RCE by Any Authenticated Mattermost User
- CVE-2025-20051 Arbitrary file read via block duplication in Mattermost Boards
- CVE-2025-25279 Arbitrary file read in Mattermost Boards via import & export board archive
Sources
Also known as GHSA-2549-xh72-qrpm, GO-2025-3379.