CVE-2025-20051 Arbitrary file read via block duplication in Mattermost Boards
An attacker can read arbitrary files on the system by duplicating a specially crafted block in Mattermost Boards.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-20051?
CVE-2025-20051 is a critical path traversal vulnerability in Mattermost Mattermost Server, published on 24 Feb 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Mattermost versions 10.4.x <= 10.4.1, 9.11.x <= 9.11.7, 10.3.x <= 10.3.2, 10.2.x <= 10.2.2 fail to properly validate input when patching and duplicating a board, which allows a user to read any arbitrary file on the system via duplicating a specially crafted block in Boards.
Weakness: CWE-22
Which versions are affected by CVE-2025-20051?
14 open source packages ship an affected version, including github.com/mattermost/mattermost/server/v8, github.com/mattermost/mattermost-server and github.com/mattermost/mattermost-server/v5. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20250122165010-4ed702ccff4e |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20250122165010-4ed702ccff4e |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20250122165010-4ed702ccff4e |
github.com/mattermost/mattermost/server/v8 Go | From 10.2.0-rc1 | 10.2.3 |
github.com/mattermost/mattermost/server/v8 Go | From 10.2.0-rc1 | 10.2.3 |
github.com/mattermost/mattermost/server/v8 Go | From 10.3.0-rc1 | 10.3.3 |
8 more packages
github.com/mattermost/mattermost/server/v8 Go | From 10.3.0-rc1 | 10.3.3 |
github.com/mattermost/mattermost/server/v8 Go | From 10.4.0-rc1 | 10.4.2 |
github.com/mattermost/mattermost/server/v8 Go | From 10.4.0-rc1 | 10.4.2 |
github.com/mattermost/mattermost/server/v8 Go | From 9.11.0-rc1 | 9.11.8 |
github.com/mattermost/mattermost/server/v8 Go | From 9.11.0-rc1 | 9.11.8 |
github.com/mattermost/mattermost-server Go | From 9.11.0-rc1+incompatible | 9.11.8+incompatible, 10.2.3+incompatible, 10.3.3+incompatible, 10.4.2+incompatible |
github.com/mattermost/mattermost-server/v5 Go | All versions | None |
github.com/mattermost/mattermost-server/v6 Go | All versions | None |
Products include Mattermost Mattermost Server.
How do I fix CVE-2025-20051?
Upgrade github.com/mattermost/mattermost/server/v8 to a fixed version for your release line: 8.0.0-20250122165010-4ed702ccff4e, 10.2.3, 10.3.3 or 10.4.2.
Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.
Is CVE-2025-20051 being exploited?
There is no known exploitation of CVE-2025-20051 in the wild and no public exploit code.
Other vulnerabilities in Mattermost Mattermost Server
- CVE-2025-12419 Account takeover on OAuth/OpenID-enabled servers
- CVE-2025-12421 Account Takeover via Code Exchange Endpoint
- CVE-2025-4981 Path Traversal Leading to RCE by Any Authenticated Mattermost User
- CVE-2025-25279 Arbitrary file read in Mattermost Boards via import & export board archive
- CVE-2016-11074 Mattermost Server: Insufficient Password-Reset Link Invalidation
Sources
Also known as GHSA-v469-7wp6-7cvp, GO-2025-3483.