CVE-2025-2008 Import Export Suite for CSV and XML Datafeed <= 7.19 - Authenticated (Subscriber+) Arbitrary File Upload
Authenticated subscribers can upload arbitrary files via CSV import, potentially leading to remote code execution on WordPress sites.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- None listed
What is CVE-2025-2008?
CVE-2025-2008 is a high-severity vulnerability in smackcoders WP Ultimate CSV Importer – Import CSV, XML & Excel into WordPress, published on 1 Apr 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
The Import Export Suite for CSV and XML Datafeed plugin for WordPress is vulnerable to arbitrary file uploads due to missing file type validation in the import_single_post_as_csv() function in all versions up to, and including, 7.19. This makes it possible for authenticated attackers, with Subscriber-level access and above, to upload arbitrary files on the affected site's server which may make remote code execution possible. Please note this vulnerability was reintroduced in 7.20, and subsequently patched again in 7.20.1.
Weakness: CWE-434
Which versions are affected by CVE-2025-2008?
How do I fix CVE-2025-2008?
No fix has been published for CVE-2025-2008 yet. Limit exposure of the affected software until one is available.
Is CVE-2025-2008 being exploited?
There is no known exploitation of CVE-2025-2008 in the wild and no public exploit code.
Sources
Also known as GHSA-rvhm-r43q-vxvx.