# CVE-2025-2113: AT Software Solutions ATSVD Esqueceu a senha sql injection

> Remote attackers can exploit SQL injection in the password recovery feature to access or modify database information.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 9 Mar 2025
- **Updated:** 10 Mar 2025
- **Also known as:** GHSA-2r4p-h6vh-pr42

## What is CVE-2025-2113?

CVE-2025-2113 is a medium-severity SQL injection vulnerability in ATSVD, published on 9 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A vulnerability was found in AT Software Solutions ATSVD up to 3.4.1. It has been rated as critical. Affected by this issue is some unknown functionality of the component Esqueceu a senha. The manipulation of the argument txtCPF leads to sql injection. The attack may be launched remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 3.4.2 is able to address this issue. It is recommended to upgrade the affected component.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command), CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component)

## Which versions are affected by CVE-2025-2113?

It affects 1 product.


Products: Atgroup Atsvd.

## How do I fix CVE-2025-2113?

No fix has been published for CVE-2025-2113 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-2113 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-2113 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-2113 and fix it if it is affected.

What it is: CVE-2025-2113 is a medium-severity SQL injection vulnerability in ATSVD, published on 9 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-2113 exists.

Affected product: ATSVD. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-2113/ (Markdown: https://insights.sbomify.com/CVE-2025-2113/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-2113
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-2113
- OSV: https://osv.dev/vulnerability/CVE-2025-2113

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-2113/
Summaries are generated and may contain mistakes; the official description above is the record.
