# CVE-2025-21171: .NET Remote Code Execution Vulnerability


- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H/E:U/RL:O/RC:C`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 14 Jan 2025
- **Updated:** 9 Jun 2026
- **Also known as:** BIT-dotnet-2025-21171, BIT-dotnet-sdk-2025-21171, BIT-powershell-2025-21171, GHSA-p54p-p3qm-8vgj, UBUNTU-CVE-2025-21171

## What is CVE-2025-21171?

CVE-2025-21171 is a high-severity vulnerability in Microsoft .Net, published on 14 Jan 2025. 

### Official description

.NET Remote Code Execution Vulnerability

Weakness: CWE-122 (Heap-based Buffer Overflow)

## Which versions are affected by CVE-2025-21171?

27 open source packages ship an affected version, including Microsoft.NetCore.App.Runtime.linux-arm, dotnet and dotnet-sdk. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `Microsoft.NetCore.App.Runtime.linux-arm` | NuGet | From 9.0.0 | 9.0.1 |
| `Microsoft.NetCore.App.Runtime.linux-arm` | NuGet | From 9.0.0 | 9.0.1 |
| `dotnet` | Bitnami | From 9.0.0 | 9.0.1 |
| `dotnet-sdk` | Bitnami | From 9.0.0 | 9.0.100 |
| `powershell` | Bitnami | From 7.5.0 | 7.5.2 |
| `Microsoft.NetCore.App.Runtime.linux-arm64` | NuGet | From 9.0.0 | 9.0.1 |
| `Microsoft.NetCore.App.Runtime.linux-arm64` | NuGet | From 9.0.0 | 9.0.1 |
| `Microsoft.NetCore.App.Runtime.linux-musl-arm` | NuGet | From 9.0.0 | 9.0.1 |
| `Microsoft.NetCore.App.Runtime.linux-musl-arm` | NuGet | From 9.0.0 | 9.0.1 |
| `Microsoft.NetCore.App.Runtime.linux-musl-arm64` | NuGet | From 9.0.0 | 9.0.1 |
| `Microsoft.NetCore.App.Runtime.linux-musl-arm64` | NuGet | From 9.0.0 | 9.0.1 |
| `Microsoft.NetCore.App.Runtime.linux-musl-x64` | NuGet | From 9.0.0 | 9.0.1 |
| `Microsoft.NetCore.App.Runtime.linux-musl-x64` | NuGet | From 9.0.0 | 9.0.1 |
| `Microsoft.NetCore.App.Runtime.linux-x64` | NuGet | From 9.0.0 | 9.0.1 |
| `Microsoft.NetCore.App.Runtime.linux-x64` | NuGet | From 9.0.0 | 9.0.1 |
| `Microsoft.NetCore.App.Runtime.osx-arm64` | NuGet | From 9.0.0 | 9.0.1 |
| `Microsoft.NetCore.App.Runtime.osx-arm64` | NuGet | From 9.0.0 | 9.0.1 |
| `Microsoft.NetCore.App.Runtime.osx-x64` | NuGet | From 9.0.0 | 9.0.1 |
| `Microsoft.NetCore.App.Runtime.osx-x64` | NuGet | From 9.0.0 | 9.0.1 |
| `Microsoft.NetCore.App.Runtime.win-arm` | NuGet | From 9.0.0 | 9.0.1 |
| `Microsoft.NetCore.App.Runtime.win-arm` | NuGet | From 9.0.0 | 9.0.1 |
| `Microsoft.NetCore.App.Runtime.win-arm64` | NuGet | From 9.0.0 | 9.0.1 |
| `Microsoft.NetCore.App.Runtime.win-arm64` | NuGet | From 9.0.0 | 9.0.1 |
| `Microsoft.NetCore.App.Runtime.win-x64` | NuGet | From 9.0.0 | 9.0.1 |
| `Microsoft.NetCore.App.Runtime.win-x64` | NuGet | From 9.0.0 | 9.0.1 |
| `Microsoft.NetCore.App.Runtime.win-x86` | NuGet | From 9.0.0 | 9.0.1 |
| `Microsoft.NetCore.App.Runtime.win-x86` | NuGet | From 9.0.0 | 9.0.1 |

Products: Microsoft .Net, Microsoft Powershell, Microsoft Visual Studio 2022.

## How do I fix CVE-2025-21171?

Upgrade Microsoft.NetCore.App.Runtime.linux-arm to 9.0.1 or later.

## Is CVE-2025-21171 being exploited?

There is no known exploitation of CVE-2025-21171 in the wild and no public exploit code.

## Other vulnerabilities in Microsoft .Net

- [CVE-2024-43498](https://insights.sbomify.com/CVE-2024-43498/): .NET and Visual Studio Remote Code Execution Vulnerability (critical 9.8)
- [CVE-2024-0057](https://insights.sbomify.com/CVE-2024-0057/): NET, .NET Framework, and Visual Studio Security Feature Bypass Vulnerability (critical 9.1)
- [CVE-2026-96957](https://insights.sbomify.com/CVE-2026-96957/): .NET Security Feature Bypass Vulnerability (high 8.8)
- [CVE-2026-69439](https://insights.sbomify.com/CVE-2026-69439/): .NET and Visual Studio Elevation of Privilege Vulnerability (high 8.8)
- [CVE-2026-71328](https://insights.sbomify.com/CVE-2026-71328/): .NET and Visual Studio Remote Code Execution Vulnerability (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-21171 and fix it if it is affected.

What it is: CVE-2025-21171 is a high-severity vulnerability in Microsoft .Net, published on 14 Jan 2025. 
Exploitation: There is no known exploitation of CVE-2025-21171 in the wild and no public exploit code.

Affected packages and fixed versions:
- Microsoft.NetCore.App.Runtime.linux-arm (NuGet): affected from 9.0.0; fixed in 9.0.1
- Microsoft.NetCore.App.Runtime.linux-arm (NuGet): affected from 9.0.0; fixed in 9.0.1
- dotnet (Bitnami): affected from 9.0.0; fixed in 9.0.1
- dotnet-sdk (Bitnami): affected from 9.0.0; fixed in 9.0.100
- powershell (Bitnami): affected from 7.5.0; fixed in 7.5.2
- Microsoft.NetCore.App.Runtime.linux-arm64 (NuGet): affected from 9.0.0; fixed in 9.0.1
- Microsoft.NetCore.App.Runtime.linux-arm64 (NuGet): affected from 9.0.0; fixed in 9.0.1
- Microsoft.NetCore.App.Runtime.linux-musl-arm (NuGet): affected from 9.0.0; fixed in 9.0.1
- Microsoft.NetCore.App.Runtime.linux-musl-arm (NuGet): affected from 9.0.0; fixed in 9.0.1
- Microsoft.NetCore.App.Runtime.linux-musl-arm64 (NuGet): affected from 9.0.0; fixed in 9.0.1
- Microsoft.NetCore.App.Runtime.linux-musl-arm64 (NuGet): affected from 9.0.0; fixed in 9.0.1
- Microsoft.NetCore.App.Runtime.linux-musl-x64 (NuGet): affected from 9.0.0; fixed in 9.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-21171/ (Markdown: https://insights.sbomify.com/CVE-2025-21171/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-21171
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-21171
- OSV: https://osv.dev/vulnerability/CVE-2025-21171

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-21171/
Summaries are generated and may contain mistakes; the official description above is the record.
