# CVE-2025-2148: PyTorch Tuple torch.ops.profiler._call_end_callbacks_on_jit_fut memory corruption

> Remote attackers can trigger memory corruption in PyTorch's profiler callback handler, potentially leading to code execution or denial of service.

- **Severity:** Low 2.3 (`CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:P/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 10 Mar 2025
- **Updated:** 10 Mar 2025
- **Also known as:** BIT-pytorch-2025-2148, DEBIAN-CVE-2025-2148, ECHO-bc4d-ba3e-5162, GHSA-c678-jfcj-6jmf, PYSEC-2025-189, UBUNTU-CVE-2025-2148

## What is CVE-2025-2148?

CVE-2025-2148 is a low-severity memory corruption vulnerability in PyTorch, published on 10 Mar 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

A vulnerability was found in PyTorch 2.6.0+cu124. It has been declared as critical. Affected by this vulnerability is the function torch.ops.profiler._call_end_callbacks_on_jit_fut of the component Tuple Handler. The manipulation of the argument None leads to memory corruption. The attack can be launched remotely. The complexity of an attack is rather high. The exploitation appears to be difficult.

Weakness: CWE-119 (Improper Restriction of Operations within the Bounds of a Memory Buffer)

## Which versions are affected by CVE-2025-2148?

4 open source packages ship an affected version, including pytorch and torch. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pytorch` | Bitnami | From 2.6.0 | 2.7.0 |
| `torch` | PyPI | All versions to 2.6.0 | None |
| `torch` | PyPI | All versions to 2.6.0 | None |
| `torch` | PyPI | All versions to 2.6.0-cu124 | None |

Products: Linuxfoundation Pytorch.

## How do I fix CVE-2025-2148?

Upgrade pytorch to 2.7.0 or later.

## Is CVE-2025-2148 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-2148 exists.

## Other vulnerabilities in PyTorch

- [CVE-2024-48063](https://insights.sbomify.com/CVE-2024-48063/): Deserialization in n/a (critical 9.8)
- [CVE-2022-45907](https://insights.sbomify.com/CVE-2022-45907/): PyTorch vulnerable to arbitrary code execution (critical 9.8)
- [CVE-2025-32434](https://insights.sbomify.com/CVE-2025-32434/): PyTorch: `torch.load` with `weights_only=True` leads to remote code execution (critical 9.3)
- [CVE-2026-24747](https://insights.sbomify.com/CVE-2026-24747/): PyTorch Vulnerable to Remote Code Execution via Untrusted Checkpoint Files (high 8.8)
- [CVE-2024-31583](https://insights.sbomify.com/CVE-2024-31583/): Pytorch use-after-free vulnerability (high 7.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-2148 and fix it if it is affected.

What it is: CVE-2025-2148 is a low-severity memory corruption vulnerability in PyTorch, published on 10 Mar 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-2148 exists.

Affected packages and fixed versions:
- pytorch (Bitnami): affected from 2.6.0; fixed in 2.7.0
- torch (PyPI): affected all versions up to 2.6.0; no fix listed
- torch (PyPI): affected all versions up to 2.6.0; no fix listed
- torch (PyPI): affected all versions up to 2.6.0-cu124; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-2148/ (Markdown: https://insights.sbomify.com/CVE-2025-2148/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-2148
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-2148
- OSV: https://osv.dev/vulnerability/CVE-2025-2148

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-2148/
Summaries are generated and may contain mistakes; the official description above is the record.
