CVE-2025-21490 Denial of service in MySQL Server
A high-privileged attacker can cause a complete denial of service in MySQL Server via network access.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-21490?
CVE-2025-21490 is a medium-severity denial of service vulnerability in Debian Debian Linux, published on 21 Jan 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
Vulnerability in the MySQL Server product of Oracle MySQL (component: InnoDB). Supported versions that are affected are 8.0.40 and prior, 8.4.3 and prior and 9.1.0 and prior. Easily exploitable vulnerability allows high privileged attacker with network access via multiple protocols to compromise MySQL Server. Successful attacks of this vulnerability can result in unauthorized ability to cause a hang or frequently repeatable crash (complete DOS) of MySQL Server. CVSS 3.1 Base Score 4.9 (Availability impacts). CVSS Vector: (CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:H).
Weakness: CWE-770
Which versions are affected by CVE-2025-21490?
3 open source packages ship an affected version, including mariadb, mariadb-min and mysql-client. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
mariadb Bitnami | All versions | 10.5.28, 10.6.21, 10.11.11, 11.4.5, 11.7.2 |
mariadb-min Bitnami | All versions | 11.4.7, 11.8.2 |
mysql-client Bitnami | All versions | 10.6.21, 10.11.11, 11.4.5, 11.8.2 |
Linux distribution packages (4)
mariadb SUSE:Linux Enterprise Module for Package Hub 15 SP6 | All versions | 10.11.11-150600.4.10.1 |
mariadb SUSE:Linux Enterprise Module for Server Applications 15 SP6 | All versions | 10.11.11-150600.4.10.1 |
mariadb openSUSE:Leap 15.6 | All versions | 10.11.11-150600.4.10.1 |
mariadb openSUSE:Tumbleweed | All versions | 11.7.2-1.1 |
Products include Debian Debian Linux, Oracle Mysql Server.
How do I fix CVE-2025-21490?
Upgrade mariadb to a fixed version for your release line: 10.5.28, 10.6.21, 10.11.11 or 11.4.5.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2025-21490 being exploited?
There is no known exploitation of CVE-2025-21490 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as ALPINE-CVE-2025-21490, AZL-58383, AZL-58408, AZL-58431, AZL-58434, BELL-CVE-2025-21490 and 23 more.