# CVE-2025-21490: Denial of service in MySQL Server

> A high-privileged attacker can cause a complete denial of service in MySQL Server via network access.

- **Severity:** Medium 4.9 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Jan 2025
- **Updated:** 3 Nov 2025
- **Also known as:** ALPINE-CVE-2025-21490, AZL-58383, AZL-58408, AZL-58431, AZL-58434, BELL-CVE-2025-21490, BIT-mariadb-2025-21490, BIT-mariadb-min-2025-21490, BIT-mysql-client-2025-21490, DEBIAN-CVE-2025-21490, DLA-4074-1, GHSA-rh26-2566-h5m7, MGASA-2025-0047, MINI-8vcv-638v-c228, MINI-9773-76x8-mpw6, MINI-chxv-j3gm-vj3j, MINI-fj2x-8r98-rqqf, MINI-j43c-pvf4-2qrc, MINI-pj2c-2x6q-mc9f, MINI-r3m3-8qv8-v3w6, MINI-wmvm-r2m2-6hqg, OESA-2025-1437, OESA-2025-1438, OESA-2025-1480, SUSE-SU-2025:01716-1, UBUNTU-CVE-2025-21490, USN-7376-1, USN-7376-2, openSUSE-SU-2025:14826-1

## What is CVE-2025-21490?

CVE-2025-21490 is a medium-severity denial of service vulnerability in Debian Debian Linux, published on 21 Jan 2025. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Vulnerability in the MySQL Server product of Oracle MySQL (component: InnoDB).  Supported versions that are affected are 8.0.40 and prior, 8.4.3 and prior and  9.1.0 and prior. Easily exploitable vulnerability allows high privileged attacker with network access via multiple protocols to compromise MySQL Server.  Successful attacks of this vulnerability can result in unauthorized ability to cause a hang or frequently repeatable crash (complete DOS) of MySQL Server. CVSS 3.1 Base Score 4.9 (Availability impacts).  CVSS Vector: (CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:H).

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2025-21490?

3 open source packages ship an affected version, including mariadb, mariadb-min and mysql-client. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mariadb` | Bitnami | All versions | 10.5.28, 10.6.21, 10.11.11, 11.4.5, 11.7.2 |
| `mariadb-min` | Bitnami | All versions | 11.4.7, 11.8.2 |
| `mysql-client` | Bitnami | All versions | 10.6.21, 10.11.11, 11.4.5, 11.8.2 |
| `mariadb` | SUSE:Linux Enterprise Module for Package Hub 15 SP6 | All versions | 10.11.11-150600.4.10.1 |
| `mariadb` | SUSE:Linux Enterprise Module for Server Applications 15 SP6 | All versions | 10.11.11-150600.4.10.1 |
| `mariadb` | openSUSE:Leap 15.6 | All versions | 10.11.11-150600.4.10.1 |
| `mariadb` | openSUSE:Tumbleweed | All versions | 11.7.2-1.1 |

Products: Debian Debian Linux, Oracle Mysql Server.

## How do I fix CVE-2025-21490?

Upgrade mariadb to a fixed version for your release line: 10.5.28, 10.6.21, 10.11.11 or 11.4.5.

## Is CVE-2025-21490 being exploited?

There is no known exploitation of CVE-2025-21490 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-21490 and fix it if it is affected.

What it is: CVE-2025-21490 is a medium-severity denial of service vulnerability in Debian Debian Linux, published on 21 Jan 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-21490 in the wild and no public exploit code.

Affected packages and fixed versions:
- mariadb (Bitnami): affected all versions; fixed in 10.5.28, 10.6.21, 10.11.11, 11.4.5, 11.7.2
- mariadb-min (Bitnami): affected all versions; fixed in 11.4.7, 11.8.2
- mysql-client (Bitnami): affected all versions; fixed in 10.6.21, 10.11.11, 11.4.5, 11.8.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-21490/ (Markdown: https://insights.sbomify.com/CVE-2025-21490/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-21490
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-21490
- OSV: https://osv.dev/vulnerability/CVE-2025-21490

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-21490/
Summaries are generated and may contain mistakes; the official description above is the record.
