# CVE-2025-21607: Success of Certain Precompile Calls not Checked in Vyper

> Attackers can manipulate gas to cause precompile calls to fail silently, leading to incorrect smart contract execution results.

- **Severity:** Low 2.3 (`CVSS:4.0/AV:N/AC:H/AT:P/PR:L/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Jan 2025
- **Updated:** 24 Apr 2025
- **Also known as:** GHSA-vgf2-gvx8-xwc3, PYSEC-2025-33

## What is CVE-2025-21607?

CVE-2025-21607 is a low-severity vulnerability in vyperlang vyper, published on 14 Jan 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Vyper is a Pythonic Smart Contract Language for the EVM. When the Vyper Compiler uses the precompiles EcRecover (0x1) and Identity (0x4), the success flag of the call is not checked. As a consequence an attacker can provide a specific amount of gas to make these calls fail but let the overall execution continue. Then the execution result can be incorrect. Based on EVM's rules, after the failed precompile the remaining code has only 1/64 of the pre-call-gas left (as 63/64 were forwarded and spent). Hence, only fairly simple executions can follow the failed precompile calls. Therefore, we found no significantly impacted real-world contracts. None the less an advisory has been made out of an abundance of caution. This issue is fixed in 0.4.1.

Weakness: CWE-670 (Always-Incorrect Control Flow Implementation)

## Which versions are affected by CVE-2025-21607?

3 open source packages ship an affected version, including vyper. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vyper` | PyPI | All versions | None |
| `vyper` | PyPI | All versions | None |
| `vyper` | PyPI | All versions | 0.4.1 |

Products: Vyperlang Vyper.

## How do I fix CVE-2025-21607?

Upgrade vyper to 0.4.1 or later.

## Is CVE-2025-21607 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-21607 exists.

## Other vulnerabilities in vyperlang vyper

- [CVE-2024-24563](https://insights.sbomify.com/CVE-2024-24563/): Vyper array negative index vulnerability (critical 9.8)
- [CVE-2024-24561](https://insights.sbomify.com/CVE-2024-24561/): Vyper bounds check on built-in `slice()` function can be overflowed (critical 9.8)
- [CVE-2023-39363](https://insights.sbomify.com/CVE-2023-39363/): Vyper incorrectly allocated named re-entrancy locks (critical 9.1)
- [CVE-2022-24845](https://insights.sbomify.com/CVE-2022-24845/): Integer bounds error in Vyper (high 8.8)
- [CVE-2022-29255](https://insights.sbomify.com/CVE-2022-29255/): Multiple evaluation of contract address in call in vyper (high 8.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-21607 and fix it if it is affected.

What it is: CVE-2025-21607 is a low-severity vulnerability in vyperlang vyper, published on 14 Jan 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-21607 exists.

Affected packages and fixed versions:
- vyper (PyPI): affected all versions; no fix listed
- vyper (PyPI): affected all versions; no fix listed
- vyper (PyPI): affected all versions; fixed in 0.4.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-21607/ (Markdown: https://insights.sbomify.com/CVE-2025-21607/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-21607
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-21607
- OSV: https://osv.dev/vulnerability/CVE-2025-21607

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-21607/
Summaries are generated and may contain mistakes; the official description above is the record.
