{"answers":{"affected":"2 open source packages ship an affected version, including trix.","exploited":"There is no known exploitation of CVE-2025-21610 in the wild and no public exploit code.","fix":"Upgrade trix to 2.1.12 or later.","what":"CVE-2025-21610 is a medium-severity cross-site scripting vulnerability in basecamp trix, published on 3 Jan 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-21610 and fix it if it is affected.\n\nWhat it is: CVE-2025-21610 is a medium-severity cross-site scripting vulnerability in basecamp trix, published on 3 Jan 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2025-21610 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- trix (npm): affected all versions; fixed in 2.1.12\n- trix (npm): affected all versions; fixed in 2.1.12\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-21610/ (Markdown: https://insights.sbomify.com/CVE-2025-21610/index.md)","id":"CVE-2025-21610","markdown":"https://insights.sbomify.com/CVE-2025-21610/index.md","name":"CVE-2025-21610","record":{"aliases":["GHSA-j386-3444-qgwg"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Trix rich text editor","requires_auth":"none","summary":"Attackers can execute arbitrary JavaScript via malicious javascript: URLs in links, potentially stealing data or hijacking sessions in applications using Trix.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Trix is a what-you-see-is-what-you-get rich text editor for everyday writing. Versions prior to 2.1.12 are vulnerable to cross-site scripting when pasting malicious code in the link field. An attacker could trick the user to copy\u0026paste a malicious `javascript:` URL as a link that would execute arbitrary JavaScript code within the context of the user's session, potentially leading to unauthorized actions being performed or sensitive information being disclosed. Users should upgrade to Trix editor version 2.1.12 or later to receive a patch. In addition to upgrading, affected users can disallow browsers that don't support a Content Security Policy (CSP) as a workaround for this and other cross-site scripting vulnerabilities. Set CSP policies such as script-src 'self' to ensure that only scripts hosted on the same origin are executed, and explicitly prohibit inline scripts using script-src-elem.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Trix allows Cross-site Scripting via `javascript:` url in a link","id":"CVE-2025-21610","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2025"},"n_packages":2,"n_references":4,"next":{"headline":"tgstation-server's role authorization incorrectly OR'd with user's enabled status","id":"CVE-2025-21611"},"packages":[{"ecosystem":"npm","fixed":["2.1.12"],"introduced":["0"],"last_affected":[],"package":"trix","purl":null,"source":"GHSA-j386-3444-qgwg"},{"ecosystem":"npm","fixed":["2.1.12"],"introduced":["0"],"last_affected":[],"package":"trix","purl":"pkg:npm/trix","source":"GHSA-j386-3444-qgwg"}],"prev":{"headline":"SiYuan has an arbitrary file deletion vulnerability","id":"CVE-2025-21609"},"products":["trix"],"published":"2025-01-03","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-01-03","vendors":["basecamp"]},"summary":"Attackers can execute arbitrary JavaScript via malicious javascript: URLs in links, potentially stealing data or hijacking sessions in applications using Trix.","url":"https://insights.sbomify.com/CVE-2025-21610/"}