# CVE-2025-21610: Trix allows Cross-site Scripting via `javascript:` url in a link

> Attackers can execute arbitrary JavaScript via malicious javascript: URLs in links, potentially stealing data or hijacking sessions in applications using Trix.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 3 Jan 2025
- **Updated:** 3 Jan 2025
- **Also known as:** GHSA-j386-3444-qgwg

## What is CVE-2025-21610?

CVE-2025-21610 is a medium-severity cross-site scripting vulnerability in basecamp trix, published on 3 Jan 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Trix is a what-you-see-is-what-you-get rich text editor for everyday writing. Versions prior to 2.1.12 are vulnerable to cross-site scripting when pasting malicious code in the link field. An attacker could trick the user to copy&paste a malicious `javascript:` URL as a link that would execute arbitrary JavaScript code within the context of the user's session, potentially leading to unauthorized actions being performed or sensitive information being disclosed. Users should upgrade to Trix editor version 2.1.12 or later to receive a patch. In addition to upgrading, affected users can disallow browsers that don't support a Content Security Policy (CSP) as a workaround for this and other cross-site scripting vulnerabilities. Set CSP policies such as script-src 'self' to ensure that only scripts hosted on the same origin are executed, and explicitly prohibit inline scripts using script-src-elem.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-21610?

2 open source packages ship an affected version, including trix.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `trix` | npm | All versions | 2.1.12 |
| `trix` | npm | All versions | 2.1.12 |

## How do I fix CVE-2025-21610?

Upgrade trix to 2.1.12 or later.

## Is CVE-2025-21610 being exploited?

There is no known exploitation of CVE-2025-21610 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-21610 and fix it if it is affected.

What it is: CVE-2025-21610 is a medium-severity cross-site scripting vulnerability in basecamp trix, published on 3 Jan 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-21610 in the wild and no public exploit code.

Affected packages and fixed versions:
- trix (npm): affected all versions; fixed in 2.1.12
- trix (npm): affected all versions; fixed in 2.1.12

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-21610/ (Markdown: https://insights.sbomify.com/CVE-2025-21610/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-21610
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-21610
- OSV: https://osv.dev/vulnerability/CVE-2025-21610

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-21610/
Summaries are generated and may contain mistakes; the official description above is the record.
