CVE-2025-21612 Cross-site Scripting in TabberTransclude in Extension:TabberNeue

High 8.6 Published Updated

An attacker can inject malicious scripts via page names in the TabberNeue extension, potentially compromising user sessions.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-21612?

CVE-2025-21612 is a high-severity cross-site scripting vulnerability in StarCitizenTools mediawiki-extensions-TabberNeue, published on 6 Jan 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

TabberNeue is a MediaWiki extension that allows the wiki to create tabs. Prior to 2.7.2, TabberTransclude.php doesn't escape the user-supplied page name when outputting, so an XSS payload as the page name can be used here. This vulnerability is fixed in 2.7.2.

Weakness: CWE-80, CWE-79

Which versions are affected by CVE-2025-21612?

2 open source packages ship an affected version, including starcitizentools/tabber-neue.

PackageAffectedFixed in
starcitizentools/tabber-neue PackagistFrom 1.9.12.7.2
starcitizentools/tabber-neue PackagistFrom 1.9.12.7.2

How do I fix CVE-2025-21612?

Upgrade starcitizentools/tabber-neue to 2.7.2 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2025-21612 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-21612 exists.

Sources

Also known as GHSA-4x6x-8rm8-c37j.

Is CVE-2025-21612 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free