{"answers":{"affected":"2 open source packages ship an affected version, including starcitizentools/tabber-neue.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-21612 exists.","fix":"Upgrade starcitizentools/tabber-neue to 2.7.2 or later.","what":"CVE-2025-21612 is a high-severity cross-site scripting vulnerability in StarCitizenTools mediawiki-extensions-TabberNeue, published on 6 Jan 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-21612 and fix it if it is affected.\n\nWhat it is: CVE-2025-21612 is a high-severity cross-site scripting vulnerability in StarCitizenTools mediawiki-extensions-TabberNeue, published on 6 Jan 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-21612 exists.\n\nAffected packages and fixed versions:\n- starcitizentools/tabber-neue (Packagist): affected from 1.9.1; fixed in 2.7.2\n- starcitizentools/tabber-neue (Packagist): affected from 1.9.1; fixed in 2.7.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-21612/ (Markdown: https://insights.sbomify.com/CVE-2025-21612/index.md)","id":"CVE-2025-21612","markdown":"https://insights.sbomify.com/CVE-2025-21612/index.md","name":"CVE-2025-21612","record":{"aliases":["GHSA-4x6x-8rm8-c37j"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"MediaWiki extension","requires_auth":"none","summary":"An attacker can inject malicious scripts via page names in the TabberNeue extension, potentially compromising user sessions.","user_interaction":"not_required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8.6,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-80","name":"Improper Neutralization of Script-Related HTML Tags in a Web Page"},{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"TabberNeue is a MediaWiki extension that allows the wiki to create tabs. Prior to 2.7.2, TabberTransclude.php doesn't escape the user-supplied page name when outputting, so an XSS payload as the page name can be used here. This vulnerability is fixed in 2.7.2.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Cross-site Scripting in TabberTransclude in Extension:TabberNeue","id":"CVE-2025-21612","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2025"},"n_packages":2,"n_references":3,"next":{"headline":"go-git has an Argument Injection via the URL field","id":"CVE-2025-21613"},"packages":[{"ecosystem":"Packagist","fixed":["2.7.2"],"introduced":["1.9.1"],"last_affected":[],"package":"starcitizentools/tabber-neue","purl":null,"source":"GHSA-4x6x-8rm8-c37j"},{"ecosystem":"Packagist","fixed":["2.7.2"],"introduced":["1.9.1"],"last_affected":[],"package":"starcitizentools/tabber-neue","purl":"pkg:composer/starcitizentools/tabber-neue","source":"GHSA-4x6x-8rm8-c37j"}],"prev":{"headline":"tgstation-server's role authorization incorrectly OR'd with user's enabled status","id":"CVE-2025-21611"},"products":["mediawiki-extensions-TabberNeue"],"published":"2025-01-06","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-08-26","vendors":["StarCitizenTools"]},"summary":"An attacker can inject malicious scripts via page names in the TabberNeue extension, potentially compromising user sessions.","url":"https://insights.sbomify.com/CVE-2025-21612/"}