# CVE-2025-21612: Cross-site Scripting in TabberTransclude in Extension:TabberNeue

> An attacker can inject malicious scripts via page names in the TabberNeue extension, potentially compromising user sessions.

- **Severity:** High 8.6 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Jan 2025
- **Updated:** 26 Aug 2025
- **Also known as:** GHSA-4x6x-8rm8-c37j

## What is CVE-2025-21612?

CVE-2025-21612 is a high-severity cross-site scripting vulnerability in StarCitizenTools mediawiki-extensions-TabberNeue, published on 6 Jan 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

TabberNeue is a MediaWiki extension that allows the wiki to create tabs. Prior to 2.7.2, TabberTransclude.php doesn't escape the user-supplied page name when outputting, so an XSS payload as the page name can be used here. This vulnerability is fixed in 2.7.2.

Weakness: CWE-80 (Improper Neutralization of Script-Related HTML Tags in a Web Page), CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-21612?

2 open source packages ship an affected version, including starcitizentools/tabber-neue.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `starcitizentools/tabber-neue` | Packagist | From 1.9.1 | 2.7.2 |
| `starcitizentools/tabber-neue` | Packagist | From 1.9.1 | 2.7.2 |

## How do I fix CVE-2025-21612?

Upgrade starcitizentools/tabber-neue to 2.7.2 or later.

## Is CVE-2025-21612 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-21612 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-21612 and fix it if it is affected.

What it is: CVE-2025-21612 is a high-severity cross-site scripting vulnerability in StarCitizenTools mediawiki-extensions-TabberNeue, published on 6 Jan 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-21612 exists.

Affected packages and fixed versions:
- starcitizentools/tabber-neue (Packagist): affected from 1.9.1; fixed in 2.7.2
- starcitizentools/tabber-neue (Packagist): affected from 1.9.1; fixed in 2.7.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-21612/ (Markdown: https://insights.sbomify.com/CVE-2025-21612/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-21612
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-21612
- OSV: https://osv.dev/vulnerability/CVE-2025-21612

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-21612/
Summaries are generated and may contain mistakes; the official description above is the record.
