CVE-2025-21617 Guzzle OAuth Subscriber has insufficient nonce entropy

Medium 6.3 Published Updated
Exploited in the wild
Not known
Fix
Available

What is CVE-2025-21617?

CVE-2025-21617 is a medium-severity vulnerability in guzzle oauth-subscriber, published on 6 Jan 2025.

Official description

Guzzle OAuth Subscriber signs Guzzle requests using OAuth 1.0. Prior to 0.8.1, Nonce generation does not use sufficient entropy nor a cryptographically secure pseudorandom source. This can leave servers vulnerable to replay attacks when TLS is not used. This vulnerability is fixed in 0.8.1.

Weakness: CWE-338

Which versions are affected by CVE-2025-21617?

2 open source packages ship an affected version, including guzzlehttp/oauth-subscriber.

PackageAffectedFixed in
guzzlehttp/oauth-subscriber PackagistAll versions0.8.1
guzzlehttp/oauth-subscriber PackagistAll versions0.8.1

How do I fix CVE-2025-21617?

Upgrade guzzlehttp/oauth-subscriber to 0.8.1 or later.

Is CVE-2025-21617 being exploited?

There is no known exploitation of CVE-2025-21617 in the wild and no public exploit code.

Sources

Also known as GHSA-237r-r8m4-4q88.

Is CVE-2025-21617 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free