# CVE-2025-21617: Guzzle OAuth Subscriber has insufficient nonce entropy


- **Severity:** Medium 6.3 (`CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 6 Jan 2025
- **Updated:** 6 Jan 2025
- **Also known as:** GHSA-237r-r8m4-4q88

## What is CVE-2025-21617?

CVE-2025-21617 is a medium-severity vulnerability in guzzle oauth-subscriber, published on 6 Jan 2025. 

### Official description

Guzzle OAuth Subscriber signs Guzzle requests using OAuth 1.0. Prior to 0.8.1, Nonce generation does not use sufficient entropy nor a cryptographically secure pseudorandom source. This can leave servers vulnerable to replay attacks when TLS is not used. This vulnerability is fixed in 0.8.1.

Weakness: CWE-338 (Use of Cryptographically Weak Pseudo-Random Number Generator (PRNG))

## Which versions are affected by CVE-2025-21617?

2 open source packages ship an affected version, including guzzlehttp/oauth-subscriber.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `guzzlehttp/oauth-subscriber` | Packagist | All versions | 0.8.1 |
| `guzzlehttp/oauth-subscriber` | Packagist | All versions | 0.8.1 |

## How do I fix CVE-2025-21617?

Upgrade guzzlehttp/oauth-subscriber to 0.8.1 or later.

## Is CVE-2025-21617 being exploited?

There is no known exploitation of CVE-2025-21617 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-21617 and fix it if it is affected.

What it is: CVE-2025-21617 is a medium-severity vulnerability in guzzle oauth-subscriber, published on 6 Jan 2025. 
Exploitation: There is no known exploitation of CVE-2025-21617 in the wild and no public exploit code.

Affected packages and fixed versions:
- guzzlehttp/oauth-subscriber (Packagist): affected all versions; fixed in 0.8.1
- guzzlehttp/oauth-subscriber (Packagist): affected all versions; fixed in 0.8.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-21617/ (Markdown: https://insights.sbomify.com/CVE-2025-21617/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-21617
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-21617
- OSV: https://osv.dev/vulnerability/CVE-2025-21617

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-21617/
Summaries are generated and may contain mistakes; the official description above is the record.
