{"answers":{"affected":"3 open source packages ship an affected version, including nicegui.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-21618 exists.","fix":"Upgrade nicegui to 2.9.1 or later.","what":"CVE-2025-21618 is a high-severity authentication bypass vulnerability in zauberzeug nicegui, published on 6 Jan 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-21618 and fix it if it is affected.\n\nWhat it is: CVE-2025-21618 is a high-severity authentication bypass vulnerability in zauberzeug nicegui, published on 6 Jan 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-21618 exists.\n\nAffected packages and fixed versions:\n- nicegui (PyPI): affected all versions; fixed in 2.9.1\n- nicegui (PyPI): affected all versions; fixed in 2.9.1\n- nicegui (PyPI): affected all versions; fixed in 2.9.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-21618/ (Markdown: https://insights.sbomify.com/CVE-2025-21618/index.md)","id":"CVE-2025-21618","markdown":"https://insights.sbomify.com/CVE-2025-21618/index.md","name":"CVE-2025-21618","record":{"aliases":["GHSA-v6jv-p6r8-j78w","PYSEC-2026-1705"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Python UI framework","requires_auth":"none","summary":"Attackers can hijack user sessions by exploiting shared authentication state across browser instances, including incognito modes.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-287","name":"Improper Authentication"}],"description":"NiceGUI is an easy-to-use, Python-based UI framework. Prior to 2.9.1, authenticating with NiceGUI logged in the user for all browsers, including browsers in incognito mode. This vulnerability is fixed in 2.9.1.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"NiceGUI On Air authentication issue","id":"CVE-2025-21618","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"auth_bypass","year":"2025"},"n_packages":3,"n_references":2,"next":{"headline":"GLPI allows SQL injection through the rules configuration","id":"CVE-2025-21619"},"packages":[{"ecosystem":"PyPI","fixed":["2.9.1"],"introduced":["0"],"last_affected":[],"package":"nicegui","purl":null,"source":"GHSA-v6jv-p6r8-j78w"},{"ecosystem":"PyPI","fixed":["2.9.1"],"introduced":["0"],"last_affected":[],"package":"nicegui","purl":"pkg:pypi/nicegui","source":"GHSA-v6jv-p6r8-j78w"},{"ecosystem":"PyPI","fixed":["2.9.1"],"introduced":["0"],"last_affected":[],"package":"nicegui","purl":"pkg:pypi/nicegui","source":"PYSEC-2026-1705"}],"prev":{"headline":"Guzzle OAuth Subscriber has insufficient nonce entropy","id":"CVE-2025-21617"},"products":["nicegui"],"published":"2025-01-06","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-01-06","vendors":["zauberzeug"]},"summary":"Attackers can hijack user sessions by exploiting shared authentication state across browser instances, including incognito modes.","url":"https://insights.sbomify.com/CVE-2025-21618/"}