{"answers":{"affected":"6 open source packages ship an affected version, including deno and deno_fetch.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-21620 exists.","fix":"Upgrade deno to 2.1.2 or later.","what":"CVE-2025-21620 is a high-severity vulnerability in denoland deno, published on 6 Jan 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-21620 and fix it if it is affected.\n\nWhat it is: CVE-2025-21620 is a high-severity vulnerability in denoland deno, published on 6 Jan 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-21620 exists.\n\nAffected packages and fixed versions:\n- deno (crates.io): affected all versions up to 1.46.3; no fix listed\n- deno (crates.io): affected all versions up to 1.46.3; no fix listed\n- deno (crates.io): affected from 2.0.0; fixed in 2.1.2\n- deno (crates.io): affected from 2.0.0; fixed in 2.1.2\n- deno_fetch (crates.io): affected from 0.0.1; fixed in 0.204.0\n- deno_fetch (crates.io): affected from 0.0.1; fixed in 0.204.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-21620/ (Markdown: https://insights.sbomify.com/CVE-2025-21620/index.md)","id":"CVE-2025-21620","markdown":"https://insights.sbomify.com/CVE-2025-21620/index.md","name":"CVE-2025-21620","record":{"aliases":["GHSA-f27p-cmv8-xhm6"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Deno runtime","requires_auth":"none","summary":"Deno leaks Authorization headers to cross-origin domains during redirects, exposing sensitive credentials to unintended recipients.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-200","name":"Exposure of Sensitive Information to an Unauthorized Actor"}],"description":"Deno is a JavaScript, TypeScript, and WebAssembly runtime with secure defaults. When you send a request with the Authorization header to one domain, and the response asks to redirect to a different domain, Deno'sfetch() redirect handling creates a follow-up redirect request that keeps the original Authorization header, leaking its content to that second domain. This vulnerability is fixed in 2.1.2.","ecosystems":["crates.io"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Deno's authorization headers not dropped when redirecting cross-origin","id":"CVE-2025-21620","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"information_disclosure","year":"2025"},"n_packages":6,"n_references":1,"next":{"headline":"GeoServer Reflected Cross-Site Scripting (XSS) vulnerability in WMS GetFeatureInfo HTML format","id":"CVE-2025-21621"},"packages":[{"ecosystem":"crates.io","fixed":[],"introduced":["0"],"last_affected":["1.46.3"],"package":"deno","purl":null,"source":"GHSA-f27p-cmv8-xhm6"},{"ecosystem":"crates.io","fixed":[],"introduced":["0"],"last_affected":["1.46.3"],"package":"deno","purl":"pkg:cargo/deno","source":"GHSA-f27p-cmv8-xhm6"},{"ecosystem":"crates.io","fixed":["2.1.2"],"introduced":["2.0.0"],"last_affected":[],"package":"deno","purl":null,"source":"GHSA-f27p-cmv8-xhm6"},{"ecosystem":"crates.io","fixed":["2.1.2"],"introduced":["2.0.0"],"last_affected":[],"package":"deno","purl":"pkg:cargo/deno","source":"GHSA-f27p-cmv8-xhm6"},{"ecosystem":"crates.io","fixed":["0.204.0"],"introduced":["0.0.1"],"last_affected":[],"package":"deno_fetch","purl":null,"source":"GHSA-f27p-cmv8-xhm6"},{"ecosystem":"crates.io","fixed":["0.204.0"],"introduced":["0.0.1"],"last_affected":[],"package":"deno_fetch","purl":"pkg:cargo/deno_fetch","source":"GHSA-f27p-cmv8-xhm6"}],"prev":{"headline":"GLPI allows SQL injection through the rules configuration","id":"CVE-2025-21619"},"products":["deno"],"published":"2025-01-06","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-01-07","vendors":["denoland"]},"summary":"Deno leaks Authorization headers to cross-origin domains during redirects, exposing sensitive credentials to unintended recipients.","url":"https://insights.sbomify.com/CVE-2025-21620/"}