# CVE-2025-21628: Chatwoot has a Blind SQL-injection in Conversation and Contacts filters

> Authenticated attackers can execute arbitrary SQL queries via unsanitized filter inputs in Chatwoot, potentially reading or modifying data.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Jan 2025
- **Updated:** 9 Jan 2025
- **Also known as:** CLEANSTART-2026-IL49737, GHSA-g8f9-hh83-rcq9

## What is CVE-2025-21628?

CVE-2025-21628 is a critical SQL injection vulnerability in chatwoot, published on 9 Jan 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Chatwoot is a customer engagement suite. Prior to 3.16.0, conversation and contact filters endpoints did not sanitize the input of query_operator passed from the frontend or the API. This provided any actor who is authenticated, an attack vector to run arbitrary SQL within the filter query by adding a tautological WHERE clause. This issue is patched with v3.16.0.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2025-21628?

It affects 1 product.


Products: Chatwoot Chatwoot.

## How do I fix CVE-2025-21628?

Upgrade to a fixed version.

## Is CVE-2025-21628 being exploited?

There is no known exploitation of CVE-2025-21628 in the wild and no public exploit code.

## Other vulnerabilities in chatwoot

- [CVE-2022-3741](https://insights.sbomify.com/CVE-2022-3741/): Improper Restriction of Excessive Authentication Attempts in chatwoot/chatwoot (critical 9.4)
- [CVE-2022-0542](https://insights.sbomify.com/CVE-2022-0542/): Cross-site Scripting (XSS) - DOM in chatwoot/chatwoot (high 8.8)
- [CVE-2022-1022](https://insights.sbomify.com/CVE-2022-1022/): Cross-site Scripting (XSS) - Stored in chatwoot/chatwoot (high 8.1)
- [CVE-2021-3742](https://insights.sbomify.com/CVE-2021-3742/): Server-Side Request Forgery (SSRF) in chatwoot/chatwoot (high 7.9)
- [CVE-2021-3741](https://insights.sbomify.com/CVE-2021-3741/): Stored Cross-site Scripting (XSS) in chatwoot/chatwoot (high 7.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-21628 and fix it if it is affected.

What it is: CVE-2025-21628 is a critical SQL injection vulnerability in chatwoot, published on 9 Jan 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-21628 in the wild and no public exploit code.

Affected product: chatwoot. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-21628/ (Markdown: https://insights.sbomify.com/CVE-2025-21628/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-21628
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-21628
- OSV: https://osv.dev/vulnerability/CVE-2025-21628

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-21628/
Summaries are generated and may contain mistakes; the official description above is the record.
