# CVE-2025-2173: libzvbi conv.c vbi_strndup_iconv_ucs2 uninitialized pointer


- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 11 Mar 2025
- **Updated:** 11 Mar 2025
- **Also known as:** DEBIAN-CVE-2025-2173, OESA-2025-1329, OESA-2025-1331, OESA-2025-1332, UBUNTU-CVE-2025-2173

## What is CVE-2025-2173?

CVE-2025-2173 is a medium-severity vulnerability in libzvbi, published on 11 Mar 2025. 

### Official description

A vulnerability was found in libzvbi up to 0.2.43. It has been classified as problematic. Affected is the function vbi_strndup_iconv_ucs2 of the file src/conv.c. The manipulation of the argument src_length leads to uninitialized pointer. It is possible to launch the attack remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 0.2.44 is able to address this issue. The patch is identified as 8def647eea27f7fd7ad33ff79c2d6d3e39948dce. It is recommended to upgrade the affected component. The code maintainer was informed beforehand about the issues. She reacted very fast and highly professional.

Weakness: CWE-908 (Use of Uninitialized Resource), CWE-824 (Access of Uninitialized Pointer)

## Which versions are affected by CVE-2025-2173?

It affects 1 product.


Products: Zapping-Vbi Zvbi.

## How do I fix CVE-2025-2173?

Upgrade to a fixed version.

## Is CVE-2025-2173 being exploited?

There is no known exploitation of CVE-2025-2173 in the wild and no public exploit code.

## Other vulnerabilities in libzvbi

- [CVE-2025-2174](https://insights.sbomify.com/CVE-2025-2174/): libzvbi conv.c vbi_strndup_iconv_ucs2 integer overflow (medium 6.9)
- [CVE-2025-2176](https://insights.sbomify.com/CVE-2025-2176/): libzvbi io-sim.c vbi_capture_sim_load_caption integer overflow (medium 6.9)
- [CVE-2025-2177](https://insights.sbomify.com/CVE-2025-2177/): libzvbi search.c vbi_search_new integer overflow (medium 6.9)
- [CVE-2025-2175](https://insights.sbomify.com/CVE-2025-2175/): libzvbi _vbi_strndup_iconv integer overflow (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-2173 and fix it if it is affected.

What it is: CVE-2025-2173 is a medium-severity vulnerability in libzvbi, published on 11 Mar 2025. 
Exploitation: There is no known exploitation of CVE-2025-2173 in the wild and no public exploit code.

Affected product: libzvbi. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-2173/ (Markdown: https://insights.sbomify.com/CVE-2025-2173/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-2173
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-2173
- OSV: https://osv.dev/vulnerability/CVE-2025-2173

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-2173/
Summaries are generated and may contain mistakes; the official description above is the record.
