CVE-2025-2175 libzvbi _vbi_strndup_iconv integer overflow

Medium 5.3 Published Updated

An integer overflow in libzvbi allows remote attackers to cause a denial of service via crafted input.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2025-2175?

CVE-2025-2175 is a medium-severity vulnerability in libzvbi, published on 11 Mar 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

A vulnerability was found in libzvbi up to 0.2.43. It has been rated as problematic. Affected by this issue is the function _vbi_strndup_iconv. The manipulation leads to integer overflow. The attack may be launched remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 0.2.44 is able to address this issue. It is recommended to upgrade the affected component. The code maintainer was informed beforehand about the issues. She reacted very fast and highly professional.

Weakness: CWE-190, CWE-189

Which versions are affected by CVE-2025-2175?

It affects 1 product.

Products include Zapping-Vbi Zvbi.

How do I fix CVE-2025-2175?

Upgrade to a fixed version.

Is CVE-2025-2175 being exploited?

There is no known exploitation of CVE-2025-2175 in the wild and no public exploit code.

Sources

Also known as DEBIAN-CVE-2025-2175, GHSA-c5fh-wq58-2973, OESA-2025-1354, OESA-2025-1355, OESA-2025-2073, UBUNTU-CVE-2025-2175.

Is CVE-2025-2175 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free