{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-2175 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2025-2175 is a medium-severity vulnerability in libzvbi, published on 11 Mar 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-2175 and fix it if it is affected.\n\nWhat it is: CVE-2025-2175 is a medium-severity vulnerability in libzvbi, published on 11 Mar 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2025-2175 in the wild and no public exploit code.\n\nAffected product: libzvbi. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-2175/ (Markdown: https://insights.sbomify.com/CVE-2025-2175/index.md)","id":"CVE-2025-2175","markdown":"https://insights.sbomify.com/CVE-2025-2175/index.md","name":"CVE-2025-2175","record":{"aliases":["DEBIAN-CVE-2025-2175","GHSA-c5fh-wq58-2973","OESA-2025-1354","OESA-2025-1355","OESA-2025-2073","UBUNTU-CVE-2025-2175"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"VBI decoding library","requires_auth":"none","summary":"An integer overflow in libzvbi allows remote attackers to cause a denial of service via crafted input.","user_interaction":"required","vuln_class":"integer_overflow"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"zvbi","vendor":"zapping-vbi"}],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-190","name":"Integer Overflow or Wraparound"},{"id":"CWE-189","name":null}],"description":"A vulnerability was found in libzvbi up to 0.2.43. It has been rated as problematic. Affected by this issue is the function _vbi_strndup_iconv. The manipulation leads to integer overflow. The attack may be launched remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 0.2.44 is able to address this issue. It is recommended to upgrade the affected component. The code maintainer was informed beforehand about the issues. She reacted very fast and highly professional.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"libzvbi _vbi_strndup_iconv integer overflow","id":"CVE-2025-2175","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"integer_overflow","year":"2025"},"n_packages":0,"n_references":5,"next":{"headline":"libzvbi io-sim.c vbi_capture_sim_load_caption integer overflow","id":"CVE-2025-2176"},"packages":[],"prev":{"headline":"libzvbi conv.c vbi_strndup_iconv_ucs2 integer overflow","id":"CVE-2025-2174"},"products":["libzvbi"],"published":"2025-03-11","related":[{"cvss_score":6.9,"headline":"libzvbi conv.c vbi_strndup_iconv_ucs2 uninitialized pointer","id":"CVE-2025-2173","kev_date_added":null,"published":"2025-03-11"},{"cvss_score":6.9,"headline":"libzvbi conv.c vbi_strndup_iconv_ucs2 integer overflow","id":"CVE-2025-2174","kev_date_added":null,"published":"2025-03-11"},{"cvss_score":6.9,"headline":"libzvbi io-sim.c vbi_capture_sim_load_caption integer overflow","id":"CVE-2025-2176","kev_date_added":null,"published":"2025-03-11"},{"cvss_score":6.9,"headline":"libzvbi search.c vbi_search_new integer overflow","id":"CVE-2025-2177","kev_date_added":null,"published":"2025-03-11"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-03-11","vendors":["n/a"]},"summary":"An integer overflow in libzvbi allows remote attackers to cause a denial of service via crafted input.","url":"https://insights.sbomify.com/CVE-2025-2175/"}