CVE-2025-2177 libzvbi search.c vbi_search_new integer overflow

Medium 6.9 Published Updated

An integer overflow in libzvbi allows remote attackers to cause denial of service or potentially execute code via crafted input.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-2177?

CVE-2025-2177 is a medium-severity vulnerability in libzvbi, published on 11 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

A vulnerability classified as critical was found in libzvbi up to 0.2.43. This vulnerability affects the function vbi_search_new of the file src/search.c. The manipulation of the argument pat_len leads to integer overflow. The attack can be initiated remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 0.2.44 is able to address this issue. The patch is identified as ca1672134b3e2962cd392212c73f44f8f4cb489f. It is recommended to upgrade the affected component. The code maintainer was informed beforehand about the issues. She reacted very fast and highly professional.

Weakness: CWE-190, CWE-189

Which versions are affected by CVE-2025-2177?

It affects 1 product.

Products include Zapping-Vbi Zvbi.

How do I fix CVE-2025-2177?

Upgrade to a fixed version.

Is CVE-2025-2177 being exploited?

There is no known exploitation of CVE-2025-2177 in the wild and no public exploit code.

Sources

Also known as DEBIAN-CVE-2025-2177, GHSA-7v7c-88p8-g95g, UBUNTU-CVE-2025-2177.

Is CVE-2025-2177 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free